Problem of Land/sea mask SNAP V6-64 Windows

I installed the new SNAP version (V 6.0.0, 15.01.2018 15:25 UTC) for Sentinel toolboxes windows 64-bit.

I’m trying to apply my graphical model to Sentinel 1 image. The model is set as follows: Read> Calibration> Multilook> Ellipsoide Correction> land / sea mask> Write.
But the result does not mask the land part. I inform you that I checked the two boxes : land/sea mask and DEM 3s.

In September 2018, I installed the same version (v6) and applying the same model, the result image masks me well the earth part. Is it the updates of January 2019 that allowed to block the link to the DEM 3s.

I thank you in advance for clarifying this problem

can you confirm that you installed all internal updates? Some trouble including SRTM were reported in this context.


Thank you Mr ABraun for response

I have updated all the plugins and the problem is corrected.


I’m missing the masking functions as well. Under “Raster” - “Masks” I can not find the function “Land/Sea Mask” anymore. There is only the option “Mask area”. I’ve updated SNAP to 6.0.7 as @ABraun showed but without success - the function is lost. Can somebody help? Thanks a lot!

you can search for any tool in the upper right corner


Thanks a lot but it does not show up there. It seems to be lost. My assumption is that it is related to some extensions which do not run clean as I’m running SNAP within my business network which has many network restrictions. I tried it on another machine outside the network and it worked fine.

you could have a look under Tools > Plugins to see if any of the major functionalities was somehow disabled.

1 Like

Unofrtunately, I’m still facing the same problem. Has anyone else had the same issue in the meanwhile? Each time, I reinstall SNAP or update to the newest version, I could not find the function for clipping anymore…