Problems with stitching two SLSTR product ( missing elements in manifest files)

I have tried to stitch two SLSTR products first with snappy and then directly in SNAP but in both cases at the end a problem with the manifest files stops the operation. Usually the stitching operators works fine so, could it be a problem of the data products?

Could you tell which products you are using? Maybe we can reproduce it.

yes, I attach here the links to the two products :‘b7bb15cd-85fb-4c29-be76-8d6803c5dcd6’)/$value‘1365c7ea-e9fa-446e-ac05-81ce967b9eb4’)/$value

or do you need the two full names?

1 Like

The problem is an unusual set of information in the data, so it is a bug within the tool.

If you can tolerate incorrect information about missing elements, you can open the xfdumanifest.xml of the earlier/more northern of the two products in an editor of your choice and exchange the entry “S8, F2” in line 632 with “S8”. The stitching tool will work then.

oh really thanks for the suggestion. I can tell you that I have tried the same operation for different products of the same location and there seems to be a similar problem. It also detect two contiguous as not contiguous. Of course I am talking about the SNAP operation, not the snappy way…