Processing NovaSAR Data

Hi. This is my first post on this forum but I have found lots of useful information here since starting to use SAR data over the last few months, so thanks to everyone who contributes their knowledge.

I have previously used the S1 Toolbox to process Sentinel-1, ICEYE, RADARSAT-2 and TerraSAR-X data but I am finding problems with the NovaSAR file that I have been given. Searching this forum, I can see a post from November last year about a new NovaSAR Reader plugin being available, but not much else since. Presumably this is because the NovaSAR system is fairly new.

I installed the NovaSAR plugin and managed to load the NovaSAR product NovaSAR_01_7650_scd_191002_220022_HH.zip into SNAP by unzipping it and then pointing SNAP to the file metadata.xml in a subdirectory. This opens the image structure in the Product Explorer window, which looks normal, but any attempt to view the Amplitude_HH band results in the error message:

java.lang.IndexOutOfBoundsException: pos < flushedPos!

The attached image shows a screenshot of the SNAP output. I have seen a similar error message previously that was caused by having insufficient RAM but I also tested the above on a different machine with 26 GB RAM so I don’t think memory is the issue in this case. Does anyone have ideas of what I’m doing wrong or has anyone successfuly used SNAP to view and process NovaSAR images?

In case it is relevant, I am using the most recent version 7.0 of SNAP on Linux and have installed version 1.1.0 of the NovaSAR Product Reader plugin. The NovaSAR image is from a region of ocean in the Pacific, north of New Zealand.

Thanks

Andrew

I think there is no need to install the plugin, since in SNAP 7. , the reader comes within the import product, this the one thing, the other thing could be successfully to be imported NovaSAR in the following way, try it up please, might be help!

I didn’t use these data before, but I think from the file reader, there is no need to unzip the file, so zip file could be read.

Hi Falah. Thanks for your response. I’ve tried every combination I could find for opening the data in SNAP:

  • using both File Open and Import;
  • with/without the NovaSAR reader;
  • zipped/unzipped data.

Unfortunately nothing seems to work. Perhaps the data may be in an uncommon mode or format, so I will contact the guys who provided the data to try and get some more details.

Re the need to unzip the file, yes I’ve always found I could open most SAR data in SNAP without unzipping (I usually use Sentinel-1 files and keep them as .zip files) but found with the early ICEYE example data that I needed to unzip it first, so tried the same thing with NovaSAR.

1 Like

Hi @middle207,

The mode of the image is a non-typical Maritime Mode image.

I couldn’t open it in QGIS, SNAP or ImageJ, however I am currently also short on RAM.

Just to eliminate any chance of the issue being RAM-related - on your 26GB system have you set up SNAP with enough maximum memory allowed by it’s JVM? Tools->Options->Performance->VM Options. The -xmx parameter indicates the memory allowed to be consumed by SNAP.

@middle207 Sorry to ask this question in the conversion.

Could you please let me know about the accessibility of NovaSAR and how I can check the availability of the archive of this sensor for my study area?

Hi all. Apologies for the delay in responding. Here is an update on what we found in case it is useful to others:

My colleague found a workaround to allow SNAP to read the NovaSAR images (you’ll need a GDAL installation to make this work):

  • Unzip the file, cd into the directory containing the TIFF files
  • Run: gdal_translate image_HH.tif temp.tif; mv temp.tif image_HH.tif

It may be neccessary to repeat this with the QL_image_HH.tif. However, after opening, there does not currently seem to be any capability within SNAP to do any processing with the image. We were unable to perform any radiometric calibration or geocoding to the image. Part of the reason for this may be because the images we have are in a non-standard maritime mode (as pointed out by dnsmcbr) which is “deliberately ambiguous in azimuth”.

Given the lack of NovaSAR product documentation available to us we are concentrating on using TerraSAR-X and RADARSAT-2 data at the moment, which are already supported within SNAP, but hope to return to this work in the future. I have heard that there is an updated version of the NovaSAR plugin (v1.1.1) soon to be released so I will update this post if we get any further with this work.

@SMJ.Mirzadeh Re the accessibility of NovaSAR data, I don’t know a huge amount about this I’m afraid. It is a relatively new system and I’m not aware of any available data archive.

NovaSAR products are already radiometrically calibrated “out-of-the-box”.

This does mean that for some of the tools within SNAP that include a calibration step, you will need to recreate the processing graph of these images with the Calibration step removed. @lveci It could be an idea to have this step bypassable with a checkbox, or some selectable No-Op cal step?

I also received the same error as described in your original post after attempting to view the bands of a maritime mode image.

I found a quick solution:

  1. Import the product as normal (using the NovaSAR Product Reader plugin):
    1.1 Select File > Import > SAR Sensors > NOVASAR
    1.2 Select the ‘metadata.xml’ file in the subdirectory of the unzipped image folder
  2. Save the product as a BEAM-DIMAP file (*.dim)
  3. Close the original product and reopen the saved .dim file

After a short while the bands should load.

I understand it’s been a while since this thread was last active, but if anyone could comment if this solution worked for them I’d be interested to know.


Relevant information:
Tested in SNAP version 7.0
NovaSAR Product Reader version 1.1.0

Original error message:

Failed to open image view.
java.lang.IndexOutOfBoundsException: pos < flushedPos!

1 Like

Hi Max. Apologies for the slow response. I attempted to replicate your solution for opening the NovaSAR product and found that it worked as long as I used a machine with sufficient RAM (it worked on machine with 50 GB but not 12 GB).

Similarly to the GDAL solution described earlier in this thread, while these steps allow us to open the bands in SNAP, there appears to be no capability to do any processing with the image. For example the radiometric calibration and geocoding operators will not work. We know from @dnsmcbr that all NovaSAR products are already radiometrically calibrated, but when opened in SNAP, only the amplitude and intensity (virtual) bands are displayed.