RADARSAT Constellation Mission (RCM) read product

Dear all,

I would like to preprocess some RCM images in SNAP. However, when I try to read the RCM product, I receive the following error:

I tried to open both the zip file and the manifast.safe file, but neither works. I am able to open the .tif files from the imagery folder, but then the metadata is not included . When I want to preprocess the product, I receive the error that this is not possible as it is not a SAR product.

NB: I work with SNAP 7.0, and have the latest updates installed.

Anyone that could help? Thank you very much in advance!

Did you try unpacking the .zip and then opening the manifest.safe?

Dear @mengdahl,

Thank you very much for reply!
Yes, I did. When I do this for a Sentinel-1 SAR image for example, indeed this works without any problem. However, when I try opening the manifast.safe file of my RCM product, I receive the same error as you can see in the image I added above (org.csa.rstb.io.rcm.RCMProductReader).

Hi @mengdahl,

Sorry for another message! Especially in these weird Covid-19 times, where things for you work probably very differently from normal I assume.

However, when you would have time; I was wondering whether you had any ideas for maybe a work-around on the RCM-reader problem? Also with the RCM test data (downloaded from ftp://ftp.asc-csa.gc.ca/users/OpenData_DonneesOuvertes/pub/RCM/ ) I receive the same error as stated above (org.csa.rstb.io.rcm.RCMProductReader), also when I try to open the Manifest.safe file.

Any ideas?
Thank you very much in advance!

All the best,
Sophie

@lveci should be able to help.