Range Doppler Terrain Correction for Sentinel 1-B images

Hi there,
I have time-series images from October 2017 to June 2018 and I did all pre-processing correctly for the Sentinel1_A of these images. However, I found the final results Black for Sentinel1_B images. I figured out that they become balck after Radiometric Terrain Flattening. I solved this problem by un-checking the “Re-grid method” box in processing parameters. So I survived that step. But now for my last step, which is the “Range Doppler Terrain Correction”. The same issue occurred. All the result data became black. I tried to play with Processing parameters options, but that did not work. Any suggestion will greatly appreciated.

likely it doesn’t have a dem for the area. you can right click on the product and add a dem band to confirm the desired dem exists in that area