Region merging segmentation outputs empty raster

Hello all

I have been trying to segment (generic region merging) a texture image from Sentinel-1. It took quite a while (between 1 and 2 h), however, when it finished the result was empty (just an array of zeroes). It might be a problem related to writing raster files after a large memory consumption? I had a similar problem with terrain flattening

I was wondering if there is any way around this? Has anybody else suffered similar issues?

Kind regards,

maybe you can first test on a very small subset if the region merging (or terrain flattening) operator produces a valid output. If not, it is not a matter of memory, but maybe the input data is not suitable.

Please test this option and report back.

Thank you!

Trying with a subset worked for segmentation, the output is not empty anymore. I also tried with TF, but as far as I know it is an issue with this specific version of snap, on the thread I mentioned before @jun_lu explained it is a known issue