S1 Slice Assembly

Hi developers,

I got an out of memory error when trying to assemble slices in snap version 0.7.

java.lang.OutOfMemoryError: Java heap space
Dumping heap to /home/cmarin/.snap/var/log/heapdump.hprof …
Heap dump file created [6563355875 bytes in 13.210 secs]

Looking to the size of heapdump created I think there is something serious going on here. I am using a machine with 16GB RAM (is this enough -Xmx13951m -Xms2048m -XX:+AggressiveOpts ??)

Hope is something easy to be solved. If you need i can provide you the message.log


Old gpt solved the issue :wink: I am still wondering if the problem was related to a lack of memory or some problem with the graphical interface…


what did you mean about old gpt ?
It works with beta 6 ?


Hi clardeux,

I meant that old style gpt is working perfectly, new style graphic interface (with probably some images opened) run out of memory…Unfortunately I don’t know if beta 06 worked properly… anyway I suggest you to always upgrade to the new beta versions if possible…