Sen2Cor-02.05.05-win64 - AttributeError: 'L2A_Tables' Object has no attribute '_L2A_Tile_PVI_File'


#1

Hello,

I am trying to process at 10 m and I continue to get this error:
AttributeError: ‘L2A_Tables’ Object has no attribute ‘_L2A_Tile_PVI_File’
Is anyone familiar with this/ have any solutions?

Thanks in advance,

Addy


SEN2COR tool
#2

Hi,

I got the same error, and solved it by processing 20 m first.

Some parameters seems to be messed up when the 10 m function tries to call the 20 m one.

Cheers,
Nils


#3

Hello,

Thank you for the reply. Would you mind explaining to me how I might do this? When I attempt to include the 20 m into the processing I get an error asking for the L1C and that it doesn’t fit a certain mask.

Thank you again,

Ashley


#4

Dear Users,

In order to run Sen2Cor 2.5.5 at 10m resolution, you do not have to specify the ‘–resolution’ field.

Please perform the following steps to process Sen2Cor at 10m resolution:

  1. go in the folder containing the ‘L2A_Process.bat’ (e.g. “C:\Sen2Cor-02.05.05-win64”)
  2. digit “L2A_Process.bat [directory_name]”
    –> e.g. "L2A_Process.bat C:\S2A_MSIL1C_20170316T094021_N0204_R036_T33SVB_20170316T094506.SAFE

To run Sen2Cor at 20m resolution:
“L2A_Process.bat --resolution 20 [directory_name]”
–> e.g. “L2A_Process.bat --resolution 20 C:\S2A_MSIL1C_20170316T094021_N0204_R036_T33SVB_20170316T094506.SAFE”

To run Sen2Cor at 60m resolution:
“L2A_Process.bat --resolution 60 [directory_name]”
–> e.g. “L2A_Process.bat --resolution 60 C:\S2A_MSIL1C_20170316T094021_N0204_R036_T33SVB_20170316T094506.SAFE”

Best Regards,
Fabrizio


#5

There is no way to generate the 10 m on its own? Thank you. This was helpful!


#6

Is that the solution of the problem with 10m resolution?. It would be important to know I think @OHagolle


#7

I do confirm that running sen2cor standalone without specifying the resolution will return the 10m level2 product with no errors.


#8

Hi, I can confirm it works. Thanks for the answers !
Olivier