Sen2cor (detailled instructions)

“Memory Error” indicates that your computer couldn’t provide the required processing capacities.

there is 8 G in folder C, it does not sufficient?

it’s not the free space but the memory (RAM).

Hi all, I have been trying to use sen2cor for some time now and was only able to run it successfully once for a 2018 image. I am currently getting this error message. Can any help? SNAP also doesn’t recognise some 2015 and 2016 files. I am not sure what the problem is.

Thanks for the good explanation ABraun. I have struggled with this plugin. I did everything you mentioned and it works well for the 60m processing. However for the 10m I get this message and the process stops after 30-40% of the processing… apparently the '_L2A_Tile_PVI_File"is missing in the “L2A_Tables”…

1 Like

did you try running sen2cor from the command line as described here? Sen2Cor-02.05.05-win64 - AttributeError: 'L2A_Tables' Object has no attribute '_L2A_Tile_PVI_File'

HELLO how i CAN creat a sen2COR HOME I NEED HELP

please have a look here:

thanks the sen2cor is well installed

The sen2cor finally worked to me, but it is really strange because I installed it on three different computers (Window) by following the same procedure and it works just on one computer. I cannot explain why. But, finally, that’s it.

Dear nicola.colaninno,

although this is might not be the issue for you, I cite it as someone else might have a similar problem. I couldn’t make sen2cor run full( DEM etc use for topograpic etc correction as well) at first because my user name included a gap between letters (xxx yyyy). I created another user account (xxxyyy) installing there all relevant sen2cor folders and sen2cor run.

I still have an issue with the metadata (syntax error) but I am working on it. I have seen another post on this topic so I will address that one when eventually I solve it or not.

Best regards,

Dear colleagues
Although i tried everything, rein installing and clean installing the toolbox and the plugin again, nothing worked. Every time, i get the same error, image below.

Dear Thiseas,

I am wondering If you have created the folder sen2cor inside your documents, since the message says that it cannot be found. It is not created automatically while installing the sen2cor plugin.
Are you trying to run the sen2cor on default parameter settings for just atmospheric correction or are you trying to apply topographic correction as well, using DEM?

All the best,

Dear Anastasia, thx a lot for replying!
I created the folder “sen2cor” inside documents (C:\Users\Theodor\Documents\sen2cor). Right click in documents, then creating new folder and naming it “sen2cor”…is that right?. I don’t understand how the end of the directory …\2.5\log has been created. i have also created a path into system variables (C:\Users\Theodor.snap\auxdata\Sen2Cor-02.05.05-win64) and a path in user variables (C:\Users\Theodor\Documents\sen2cor). i I noticed that in my user name directory there are 2 files at the end, called “auxdata” & “label” as shown in the img below, maybe this is the prob?
I am just trying to run the sen2cor on default parameter settings for just atmospheric correction.

Dear Thiseas,

After you create the sen2cor folder inside user’s Documents, when you run sen2cor for the first time a)the folder 2.5 and b)the folder cfg inside of 2.5, as well as c)the file L2A_GIPP.xml inside cfg folder will be created automatically .

Bear also in mind that the first time you run sen2cor after its installation, a bundle is requested to be installed. After accepting the installation, the respective folder is created here:

Have you accepted the installation of the bundle? I think you shouldn’t create the folder yourself.
Furthermore, I don’t have these files that you have inside my documents i.e. auxdata and label.

I am also new in using sen2cor but I have managed to run it properly for atmospheric correction after consulting various forum posts etc. I am having some problems with the properly implementation of the topographic correction and I have posted my questions here GIP_TL.xml file not created with Sen2Cor 2.5.5 but unfortunately I have received no feedback yet.

All the best,

Dear Anastasia
yes indeed, i have accepted the installation of the bundle but it seems that the steps a),b),c) have not been created automatically.(i guess all these 3 steps concern the “C:\Users\Theodor\Documents\sen2cor” directory.
I will reinstall and install all of them from the scratch, many thanks about the instructions.

Best regards

Hello, i guess i found out what the prob is. whenever am trying to execute the sen2core, i get a message like the one shown below in the img

In the directory C:Users/Theodor/Documents/sen2cor, the word Documents starts with a capital letter D.
Is it right to rename the Documents folder? (bcz its a system folder). Or do i have to create a new directory?
I tried command line using mkdir but the system doesn’t approve the creation of a new folder called documents, bcz there is already a folder called Document.
Plz help, am not familiarized in cmd program and can’t proceed in the use of sen2cor tool.
i also post an img of sen2cor tool settings inside SNAP

you can define any folder for SEN2COR_HOME as long as it exists
So the easier way is to create a folder for these files and then post this directory in the value you highligted above. Sen2cor 2.4.0 on SNAP 6.0

I created a file called ‘‘sen2cor’’ in documents, but how do i post this directory in that value?(using command line?)
i also created the directory in user variables. img below

Best regards

Solved it!
ABraun, many thanks about the instructions above.(added the variable ‘‘sen2cor’’ in the sytems variable. The only i have to mention, i had to add the python.exe in win security/Allow an app through controlled folder access. (a notification appeared that python.exe was blocked soon after the sen2cor process started).

p.s. i followed the instructions of this post Sen2cor 2.4.0 on SNAP 6.0 but in my case i use the Sen2Cor-02.05.05-win64 on SNAP 6.0

1 Like