Sen2cor does not work

Dear all,
I am trying to apply sen2cor to image S2B_MSIL1C_20190410T075619_N0207_R035_T40WEB_20190410T114209
with following parameters:

Sen2Cor-post-template.vm ALL false Sen2Cor-gipp-template.xsl Sen2Cor-gipp-template.xsl 1 0 MARITIME WINTER h - 331 1 1 1 FALSE 0 0.22 23.0 0.1 0.25 NONE 0 1.0 100.0 FALSE FALSE FALSE

Sen2cor works normally, successfully finishes work but result is the same as initial image. I downloaded S2B_MSIL2A_20190410T075619_N0211_R035_T40WEB_20190410T122059 image and found that it is the same as 1C level product. Maybe there are some problems with parameters I apply?

Thanks in advance for help!

Try up to apply sen2cor as default parameters and compare, also how do you compare the result of AC, one with the L1C?

Other issue shortages the time, download directly the L2A, if it’s available!

Falah, thank you very much for response. Yes, 2A is available. I’m not very experienced in satellite image processing and just was trying to understand how sen2cor works. I expected cirrus clouds to be suppressed a liitle bit. But was frustrated that in fact only brightness has increased on 2A comparing to 1C. I compared atmospheric penetration RGB composite (bands 11, 12, 8A) to better see sea ice cover, which is the object of my study. Is it possible somehow to suppress cirrus like that on the picture?

Very much thanks in advance!

Actually you could try up , but I don’t expect any differences, I suggest to apply idepix to mask all these cirrus, and then compensate these removed pixels by the closest time of other images, free clouds and cirrus in this part. Other solution is to apply sen2three.

Falah, installed idepix, made a resample to target band. My image is centered at 68 N, so I print ASTER 1sec in digital elevation model window. All should work but i get the following error message. What am I doing wrong?

Well, 8 gb of RAM, 25 gb on disk c and it does not work

it is not a problem of RAM here. The message says that your data lies outside the SRTM coverage.


Is this true?

I don’t know exactly how to change the DEM used but maybe @marpet can help here.

@ABraun, thanks for info. I know that SRTM coverage is limited with approximately 60 N and S and my image is out of it, it is near 68 N at Pechora sea. That is why i tried to apply ASTER, but gives the same error message stating that the image is out of SRTM coverage

Well, if I apply any DEMs from the help which are supported by idepix

In any case I get the same error message))

hmm, I know that ASTER 1sec GDEM is not automatically downloaded by SNAP. But at least ACE30 should work.

You can try this: Right-click on your image and select Add elevation band


Chose one of the Auto Download ones (not SRTM) and click OK
Double click on the newly generated product “elevation” to have it downloaded and opened. It might not be very precise but at least stored at the correct location and allow you to execute IdePix afterwards.

@ABraun, thank you very much, i chose ACE30 and it uploaded to elevation_2 band, I enter it’s name to DEM window but result is the same, all is on picture

that is strange, especially because “compute mountain shadow” is not even checked… Maybe Marco has an idea.

I tried to reinstall idepix plugin and it did not help. No ideas what to do((

Yes, sorry I didn’t read the rest of message, phiweek is interesting event to be.