sen2cor error

Hi all,
Thank you in advance for your help. I’m trying to process an L1C image and I get this error:

I don’t know what I’m doing wrong.

Thanks!

The error says that some file either “doesn’t exist or [is] not a regular file”.
I can’t read the filename in your screenshot – did you check that it actually existed?

EDIT: another thing: there is a new version for Sen2Cor available, so you might want to update first and then check if the error persists.

Hi Christian,

The file exists and I’m using the last version of Sen2cor

The latest released version of Sen2Cor is 2.2.1 (see http://step.esa.int/main/third-party-plugins-2/sen2cor/) and according to the screenshot you seem to be using 2.0.6. I’m talking about the tool itself, not the SNAP plugin.

Your error might be caused by the lenght of the path, this can be solved by puting the product at the root of the path. This should be solved by updating Sen2Cor tool as well.

1 Like

I didn’t realised that I had an older version. I will try updating sen2cor itself.

I have installed the updated sen2cor tool and it is running. I hope the processed product will be fine.
Thank you very much for all your help.