SEN2COR Installation Error

I followed the instructions for the installation of SEN2COR and an receiving the above error. Any help on how to resolve the above error.

Thank you

Did you install Anaconda for your Python?

I am also not able to install sen2cor properly even after following the instruction. Though everything installed successfully but when I checked the last step i.e. “L2A_Process --help” it is showing the following error.

Can anybody help me to fix the issue?


I had the numpy.dtype error too. After installing Sen2Cor the constellation of the Versions of the packages (for example numpy) is messed up. So the numpy package does not have the expected version anymore (“has the wrong size”). In my case this worked:

pip install --upgrade numpy pip install --upgrade tables

Try typing this in your Anaconda prompt.

  1. you are working with an outdated version of sen2cor. Please use the new vesrion 2.2.1 from here:
    Read the release notes and follow the installation instructions. All your problems are related to the outdated version, as Anaconda has been upgraded and does no longer support the old versions of numpy and pytables. This is where your errors are origin and this is (among others) the reason for the new release 2.2.1. Sen2cor 2.0.6 will no longer be supported.
    cheers, Uwe

Thank you so much Omnishambles! It worked but still a bit error message but finally I fixed the issue with updated version of sen2cor.

Thank you so much umwilm! yeah the problem was with outdated version. When I installed the latest version, it worked. Thank you once again for your suggestion!

Thank you Omnishambles,
pip install --upgrade numpy
pip install --upgrade tables
shows following error,