Sen2cor installation problem - Glymur library missing


I am the whole day trying to install SEN2COR on my Windows 64 bit operating system, but I have to admit I have failed to do so.
I have downloaded the recent version sen2cor 2.3.0. Before that , as it states in the online tutorial, I have installed Anaconda 4.2.0 which runs the Python version 2.7.12.
Everything goes well until I run the script “python install” for the sen2cor package.

Initially, the detected problem was that the library (or package) glymur was missing. Then I installed the Glymur - 0.8.7 and ran the instalation process once more. Funny thing is that during the installation process I realized that the Glymur is uninstalled.

Then I thought the problem was the version of the Glymur package, and therefore I have installed the Glymur - 0.8.6. But somehow I realized that the installation process of sen2cor also deletes this version of the glymur. Unfortunately I cannot post more images per post, but the message in the command line during the process is:
->Checking for conda glymur package of version 0.8.4…
-> Uninstalling glymur-0.8.6:
-> Successfully uninstalled glymur-0.8.6
-> Collecting glymur==0.8.6

So, at the end, wehn I run the control line to check the success of the installation (“L2A_Process --help”), I get the following message:

Can anybody please send me some light here?
Thanks in advance.


firstly, I would like to highlight that this is the way questions should be asked in this forum :slight_smile:
A clear description what system and versions you are using, what you have already tried and what exactly is the problem in your case.
Good job! :+1:

As you are using the latest version of sen2cor it’s not an issue of outdated resources.

Some people were lucky with opening the command line with administrator privilleges and then installing sen2cor. (explained here)

A second thing you can try is to place the full path of your python installation into your PYTHON_BIN variable. It can be found under Manage external tools > sen2cor - Edit > System variables. Maybe a wrong python version is addressed. (explained here)

Lastly, you could check if glymur is listed in your site-packages under C:\Anaconda2\lib\site-packages (or your custom installation path respectively). If not, there is a version mismatch between different python installations.


Did you try to re-install glymur after the sen2cor installation?
conda install glymur
pip install glymur

Yes I did. And then I get another problem called: “No module named osgeo.gdal_array”, as in the image below.

There is a chance that my port-server connection is blocked by the IT guys here. Will check this out asap.

Hi. I have had the same issues as you had, Felipe. I think that I have solved it, at least in my computer. I installed Sen2Cor on Windows 7 64bit OS.

This is path I tracked:

  1. I updated my Anaconda2 to version 4.2.13 py27_0;

  2. I ran Sen2Cor Installer just as we are told to do in Sen2Cor manuals. The message that glymur 0.8.6 is missing appeared to me after I tried to run Sen2Cor Help;

  3. I looked for glymur 0.8.6 on Google and downloaded it from ;

  4. I installed glymur from GZ file content and then I had a message of a missing dependency: mock 0.7.2;

  5. I looked for mock 0.7.2 on Google and downloaded it from ;

  6. I installed mock from GZ file content and when I ran Sen2Cor Help, no error messages were displayed.

1 Like

Hi Daniel,

Thanks for your answer.
I followed the steps you described, but I still get the following error message:
“ImportError: No module named osgeo.gdal_array”.

Any idea?

Hi Felipe,

I did exactly what Daniel suggested and then got the same error as you “ImportError: No module named osgeo.gdal_array”.

To fix this I used the “conda install gdal” command in the command line. Make sure you open the command line with admin rights and also make sure, if using a proxy server, that this is not blocking the website that this command calls to download the relevant packages. Once finished check the “L2A_Process --help” command and it should return error free.

Hope this helps

You saved me the day. I had the same problem with Glymur.
For a correct installation without any errors I had to install mock 0.7.2 first and then glymur 0.8.6.