Sen2Cor Problem

I have run sen2cor tool to process the MSIL1C data product to L2A product on the new release SNAP 2.0 and the processing finished with this error message

and when I went on to open the L2A product it is not opening and I found this error message on the bottom right corner of SNAP 2.0, can some one help what this means and how to solve it. Thank you in advance.

java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
at java.util.ArrayList.rangeCheck(Unknown Source)
at java.util.ArrayList.get(Unknown Source)
at org.esa.s2tbx.dataio.s2.l2a.L2aMetadataProc.getDatastrip(
at org.esa.s2tbx.dataio.s2.l2a.L2aMetadata.initProduct(
at org.esa.s2tbx.dataio.s2.l2a.L2aMetadata.(
at org.esa.s2tbx.dataio.s2.l2a.L2aMetadata.parseHeader(
at org.esa.s2tbx.dataio.s2.l2a.Sentinel2L2AProductReader.parseHeader(
at org.esa.s2tbx.dataio.s2.ortho.Sentinel2OrthoProductReader.getMosaicProduct(
at org.esa.s2tbx.dataio.s2.Sentinel2ProductReader.readProductNodesImpl(
at org.esa.snap.core.dataio.AbstractProductReader.readProductNodes(
at org.esa.snap.core.dataio.ProductIO.readProduct(
at org.netbeans.modules.progress.ui.RunOffEDTImpl$
at org.openide.util.RequestProcessor$
[catch] at org.openide.util.RequestProcessor$

1 Like

Hi, there was a download problem when integrating the new openjpeg dll for windows. I will replace it.

1 Like


I am trying to run Sen2cor
(2.0.6) in SNAP as an external Tool.
I installed sen2cor sucessfully and the L2A_Processor is working on command
line level.
I am working on a Windows 7 64bit machine.
I am following the
discussion in the forum, but I am still having problems to create a L2A through the integrated sen2cor Tool in SNAP.
I keep getting following error:

I have tried with the command line with the same error:

Please, I would appreciate any information regarding these issues. The new
user L2 data is created but I cannot open it with SNAP anyway.

Thanks in advance.

Hi again! I have solved it. The clue was to not open previously the
files with another program (I have tried with ENVI and Qgis) and also in the
process of decompressing files, which were not able to save some of the files
because the maximum length of characters is 260 thus exceeding it. I have
changed the name with 1C_ always within and it work properly. Anyway, it gave
me another error this time associated to the Metadata file, but the L2 products
were processed correctly.