Sen2Cor: Process L1C to L2A not completed (solved)

Dear S2-users,

I’m trying to run Sen2Cor for a S2A-L1C scene since a few days. The current issue is that the output is not complete: A S2A_MSIL2A_…-folder is created, but solely the subfolders AUX_DATA (which is empty) and DATASTRIP (contains subfolder DS_SDS__… and in it MTD_DS.xml) were created.

The log-file says the following:

<?xml version="1.0" encoding="UTF-8"?>


logging for the main process initialized

validating metadata file L2A_CAL_SC_GIPP.xml against scheme

metadata file is valid

validating metadata file L2A_CAL_AC_GIPP.xml against scheme

metadata file is valid

input product origins from: S2A

validating metadata file L2A_GIPP.xml against scheme

metadata file is valid

Error in creating L2A User Product

I tried to run Sen2Cor via SNAP and via command line, but both do not create L2A-product properly. I already checked the forum for sen2cor-related solutions but none helped me to fix the problem.

Any help would be strongly appreciated!


My solution to this problem: I copied the original image folder directly to my harddrive (therewith not “hidden” in many folders). Choosing the xml-file from there in Sen2Cor made it working.