Sentinel1 image Export fails


Similar to the cases here and here I tried a product ( result of coregisteration of two S1 GRD images which contains two HH masters and two HV slaves “amplitude” rasters). I can export and save the whole product (containing 4 bands) in a .tif/.Bigtif format, however when I try to individually select each band (using the raster->subset function) the individual bands are not being exported to a new .tif file. Luckily I could manage to exploit gdal package to read and separately access each raster, but the fact that this export function does not work properly on different data formats is a pity.

It not very clear what you did exactly but there are probably workarounds if this is indeed not working. It sounds like your workflow for stacking two S-1 scenes (from the same track?) might be causing the problems.

The work flow is like this :

  1. Downloading S1-IW-GRD tiles of the same geo-location, using the same orbit information (with 12 days temporal distance among them).
  2. Using SNAP Cropping the same spatial subset from both images.
  3. Using SNAP applying orbit correction
  4. Using SNAP DEM-assisted coregistration

Now I have a co-registered data between master and slave images with 4 different amplitude bands(a master-slave pair for HH and a master-slave pair for HV polarization). At this time I want to export each one of 4 bands in a separate .tif file but it fails.

For S-1 GRDs from the same orbit track you should use Create Stack under Stack Tools. If I’m not mistaken setting resampling to "none’ should work in most/all cases.

Well I don’t see what does “stacking” has to do with “exporting” different bands of a product. I do not need to sub-sample my bands and spatially “collocate” the bands. these bands are already collocated in the process of co-registration. I want to export them individually into separate .tif files to do whatever else on them. This exporting procedure does not work on my product.

Co-registration with warping is overkill in the case of S-1 GRDs and the unneeded resampling is (slightly) degrading the data. If you plan to use the data for something quantitative you should also calibrate the radiometry and correct for geometric distortions with terrain flattening and terrain correction.

That being said it’s of course possible there is a bug that is preventing your operation. Have you tried selecting the single bands directly in export (available in the right side of export to GeoTiFF window)?

1 Like

Have you tried Band Select?

Yes I always do this through: Raster->Subset->Band Subset

Try to use this one: Raster - Data Conversion - Band Select.