SEVERE: org.esa.snap.core.dataop.dem.ElevationFile: Illegal file name format: N55E023.SRTMGL1.hgt.zip


#1

Dear s1tbx team,

I get the error in subject for a SRTM 1Sec HGT tile that was written to .snap/auxdata/dem/SRTM\ 1Sec\ HGT/ in a previous run (doing Terrain-Correction on a GRD tile). I have not changed anything in between runs. The process continues by downloading the tile from http://step.esa.int/auxdata/dem/SRTMGL1/ (twice! and once for N55E022).

GRD scene is: S1A_IW_GRDH_1SDV_20180523T043513_20180523T043538_022027_02614F_D349.zip

Although marked as SEVERE, the process completes fine. However, over scenes which are including non-existing SRTM tiles over sea (which I replace by empty “fake” tiles) this error breaks the process, obviously because it will never find the fake tile on the ESA server.

What is the reason for the error and can it, somehow, be circumvented?

Guido


#2

For info, there is nothing in:

that suggests that the error is thrown from this part. That makes it really hard to trace (and eventually solve).


#3

Not sure if it is the cause but your path looks suspect

.snap/auxdata/dem/SRTM\ 1Sec\ HGT/


#4

The path looks fine to me, checked it on my machine, same location, the / within the path, if this is what seems to be odd, are for escaping the whitespaces in the path.


#5

I’m not sure how to repeat the error. I terrain correct your scene, shut down, start up, try again, add elevation. It downloads the srtm 1 sec tiles onces and not again. What do you mean by fake tiles?


#6

Luis,

The fake tiles are related to this problem:

which was never solved. Thus, I decided to create empty tiles for sea covering tiles. This went fine until the Illegal file name format error started to pop up.

Guido


#7

Is the source code actually in sync with the latest SNAP version. It is very curious that the “Illegal file name format” error thrown by this class is nowhere in the actual code (unless it is not actual).


#8

You should not look at the ‘master’ branch. This one will be the next major release.
Have a look at the maintenace branch named ‘6.x’


#9

Thanks Marco,

Looks like this error has it’s origin in:

org.esa.snap.dem.dataio.srtm1_hgt.SRTM1HgtFileInfo

in a private class called EastingNorthingParser which looks like a very convoluted way to parse a tile name like N55E022, and throws so many ParseExceptions (which eventually pops up the “Illegal file name format” message) that it is impossible to guess where it fails exactly.

The code does not look inside the zipped tile at all, so what is inside doesn’t appear to matter much.

Guido