SNAP 5.0 fails to launch on Linux

For the past few weeks my team has been unable to get SNAP to launch properly on our Linux VMs. The splash screen comes up, it gets as far as “Done loading modules” and then sits doing nothing, forever. Weirdly, the problem has affected Kubuntu 16.04, Debian Jessie and CentOS 7 (with a GNOME desktop).

I’ve done most of the testing on the CentOS 7 machine, and have tried reinstalling, and updating the modules, but nothing seems to work. I’ve put the log file here:

Any help would be very much appreciated.

This happens probably due to the limited 3D capabilities of the VMs.
You can either increase the 3D capabilities by changing the VM configuration or you remove the world-wind jar from the installation.
Delete snap/modules/org-esa-snap-snap-worldwind.jar from the installation directory.
If you then start SNAP you get a warning that this module is missing. Accept it and let SNAP remember the decision.

Having removed the worldwind module, the splash screen process now completes but the Snap window never appears, despite the process not exiting.

Looking at the logs, they are full of “no splash screen available” errors. I have attached the log file from an attempt to launch with the --nosplash flag. This was run on a VM running Debian stretch, but a nearly-identical log was produced on a CentOS 7 VM. The only reference I can find to this error message online is a NetBeans bug report that claimed the problem was with Unity-Mir, which can’t apply to this situation.
messages.log (72.0 KB)

Oddly, I’ve got the same installation to run fine when tunneling X11 over an SSH connection to the VM, which leads me to suspect that this is a problem specific to our VNC connection to the VM host, which you’re unlikely to be able to diagnose. I know very little about Java GUI frameworks, though, so it’s possible there’s an easy fix I’m missing here.

I had the same problem in a linux system (debian-ubuntu). I solved by installing snap without the “sudo” command.
Usually debian users to install software must run the installation command with the “switch user” option to get elevated privileges.
On the contrary, to install snap you do not need to have elevated privileges in debian-ubuntu systems.
This was my experience,