Snap2stamps package: a free tool to automate the SNAP-StaMPS Workflow

I tried again. it did not work.

What about that?

Yes, they look good.

did you remove any of the products created in previous steps?

I just deleted the zip files of the images because there was not enough space.

thant should be fine actually.

Have you checked if the url of SRTM3Sec has changed accordingly after the latest update and of there are corrupted zip files in the aux directoy (both explained in the link above). I know the export should not require SRTM data at all, but this has caused lots of trouble lately. Problem in the last part of snap to stamps

I want to start with stamps in matlab, Do I have to set the Insar_processor to Snap to run the Stamps step (1,8)? or gamma?

if you prepared the data in SNAP you set it to ‘snap’

ok.thanks , I set it to ‘snap’ then run stamps(1,1), see this error, What is the cause?

(Ubuntu 20.04, python-3.8)
I’m trying to run “” but it seems there is an error with the subprocess.Popen() function. It just doesn’t wait for the processes to finish, I mean it gives me the following output:
…[13] Finished process in 2.7949752807617188 seconds.
Split slave [’/app/Documents/snap2stamps/SAR/PROC/slaves/20201226/’] successfully completed.

But the split folder is empty. So I tried running the command manually from the command line:
~/snap/bin/gpt /…/snap2stamps/SAR/PROC/graphs/splitgraph2run.xml -c 5G -q 6
This time, it behaved differently - it downloaded the Orbit file and produced *.data and *.dim in the right split folder. It took more than 2.79 seconds…

So I thought, maybe if I download all the orbit files beforehand it would not have problem with the downloading part. Running the python script again didn’t change anything. Forthemore, running the command manually again still caused it to download the orbit file again.

So, my questions are:

  1. Why does the python script not working? it seems this was not an issue before.
  2. Why does the gpt downloading the orbit file by default? What to do if I would want to use it on a stand-alone station?
  3. not related to this issue - I saw that other people populated the MASTER= line in project.conf to point to a *.dim file. How can you do that if you don’t have that dim file at the beggining of the process?? You start from zip files, don’t you?

Thank you very much,

hi ABraun,
Can you tell me what is the cause of this error When I run stumps(1,1), and how should I fix it? please
Index in position 2 exceeds array bounds.

Error in ps_load_initial_gamma (line 108)

Error in stamps (line 263)

have you seen this?

I downloaded this script and put it in matlab folder on Stamps software,then run the stamps(1,1) step, but this error is still and do not fixed it.:confused:

Do you get the same error message?

Have you seen this?

I a not sure python 3.8 subprocess function runs in the same way that for 2.7 for which the original script was conceived.

Could you please verify it?

Thank you for your reply.
As I saw in, the subprocess function is suiteable for python3…
I might be wrong though.

It might work, but maybe differently.
I cannot say more… please check or just use python 2.7. Then it should work as expected.

Let me know

Yes it is exactly the same.

Yes, I have seen it. but this error is still and do not fixed for me.