Snappy not working with python 3.5


#1

The snappy-conf command seems to fail on Ubuntu 16. I think it’s a problem with Python 3.5.

I managed to get it to work by running the following before executing snappy-conf:

$ git clone https://github.com/bcdev/jpy.git
$ cd jpy/
$ python3 setup.py bdist_wheel
$ cp dist/*.whl "/home/myuser/.snap/snap-python/snappy"

Could this be added to snappy-conf so that it works with python 2, 3.4, and 3.5?

Thanks!


Python configration error for snap
#2

Thanks for this! Your script code is a Unix-only solution which we could use as fallback if the binary distribution shipped with SNAP does not match the current platform.

By default, snappy currently only works for Python 2.7, 3.3, 3.4. Support for Python 3.5 is on its way! Watch SNAP-626.


#3

Thanks Norman!

By the way, following the steps indicated above got me a working version of snappy with python 3.5. Maybe the features I’m using are not affected.


#4

Great! As long as the tests run green and there are no severe compilation warnings you can be quite sure it will work fine.

Regards
Norman


#5

This helped me too, thanks very much for posting!


#6

Hello
I have the same error now, did you fixed it?

cp dist/*.whl “C:\Users\ST.snap\snap-python\snappy”
ERROR: Configuration failed

and in windows system it gives me this message?

‘cp’ is not recognized as an internal or external command,
operable program or batch file.


#7

cp means copy some file to another place.

*.whl means the file ended with whl.

So for Windows:

Just copy the whl file being compiled to the target folder. Change the Users to your own username of Windows.

You need to display the hidden folder and files (can be set in windows) before you do this.


#8

Hi

I’ve just installed Snap 6.0 and the ./snappy-config /usr/bin/python3 (pointing to python3.5) fails with:
Configuring SNAP-Python interface…
java.io.IOException: Python configuration failed.

failed with return code 10.

Does this mean the Python 3.5 compatibility is still missing?


#9

Yes, it is still missing. But some got it to work, even with Python 3.6. I think they have used anaconda.