Unable to run PolSAR 6.0

I’ve just installed PolSARpro 6.0 (Windows x64) and the recommended additional software (Tcl/Tk, Gimp, ImageMagick and SNAP). As I try to open PolSARpro I get a window asking which program will it open with. I tried with Tcl and I just get an empty DOS windows which lasts for one second and then dissapears. I also tried to run PolSARpro from the executable file in the installation folder but still no results…

How can I run PolSARpro? Can anyone please help me?

Thanks so much,

Enrique

1 Like

TCL should be installed first
Have a look

Dear colleague,

Thank you so much for your help. I first installed Magicsplat Tcl; now I uninstalled that app and installed ActiveTcl instead. When trying to run PolSARpro Biomass I just get the warning message below:

"can’t read "Version: no such variable when executing
‘append PSPEnv $Version’
(procedure ‘InitPolSARproEnv’ line 25)
invoked from within
‘InitPolSARproEnv’
(procedure ‘init’ line 613)
invoked from within
‘init Sargc Sargv’
*(file C:\Program Files (x86)\PolSARpro_v6.0_Biomass_Edition*
PolSARpro_v6.0_Biomass_Edition.tcl line 15161)

I linked PolSARpro to wish but no way, the problem still remains and the software doesn’t run.

What can be happening?

Best regards,

Enrique

1 Like

I had the same problem (of course I hadn’t installed Magicsplat Tcl)
I just unistalled PolSAR pro
Installed ActiveTcl
And then reinstalled PolSAR pro

At the first run I guess I linked to tclsh.exe

I still have the mentioned problem using ActiveTcl or Magicsplat Tlc. Opening PolSARpro v.6 by these apps, a window of prompt commands instantly appear and disappear, but nothing else happens. Here is the error message

.