Weird behavior of Biophysical processor image subset

Hi all,

Is there anyone know what the minimum and maximum image size that Biophysical Processor could handle?
I’ve built a graph processing with below steps, but when I passed a field boundary geometry which is a rough image size of 40(w) x 40(h) at 10 m resolution returned values of -1.79769e+308. And I increased the size 5km x 5km, it seemed to be ok, but resulting image shape cuts off parts

when I tried a subset including one edge of the image which means the subset is not fully covered imaged area, some outer bounds, it also returned -1.79769e+308.

I’ve also tried to process an entire s2 scene, it seemed to take forever. Has anyone have experienced it before?

And lately, i passed wkt format polygon geometry in the “geoRegion” element of the graph process when I got 5km results, like this
POLYGON ((-87.87279567383703 39.26594878165506,
-87.80811922862252 39.26594878165506,
-87.80811922862252 39.32953589159469,
-87.87279567383703 39.32953589159469,
-87.87279567383703 39.26594878165506)) and wondering if this is the right format.

Any tips of idea would be really helpful. Thanks all