Wrongly removed topo-phase in differential phase?!

Hi, Guys,

I found some problematic interferograms produced using the differential operator with TOPS data.
The first one is the srp+topo phase I produced for comparison purpose. The second one is the standard output from the topo-phase removal step (e.g. the srd phase, or srp-topo phase). It is clear that the latter show much more fringes related with topography model than the former. So I guess that the topo-phase is probably wrongly multiplied with -1 somewhere in the code. I remember I mentioned this problem last year. Please have a check.


1 Like

Hi Jianbao,
Thank you for pointing out the problem. In order to facilitate our debugging process, could you please tell us which data products you have used in your test?


Dear Jun,

Thank you!
Here are the data I used. Please test using these data.




Hi Jianbao,

We have processed the data sets that you provided and we can repeat the problem. We’ve also reviewed the code and did not find anything wrong with it. Noticing that the two data sets were half a year apart and processed by two different processors at different facilities, we downloaded a product which is one month apart from your product and processed by the same processor as yours. We paired these products and processed again. This time we did not notice the problem you had seen. So we suspect the problem is caused by the product pair.

We have fixed an issue involving the averaged scene height (which is quite different in your scene) in the flat Earth phase. Also, there was a processor change in Nov 2015 which also affected phase and may contribute to the problem.


Hi, Jun and others,

Thank you very much for the testing.
Yes, this could be an issue of ESA’s SAR processors, which might use different parameters between different facility. I found some other cases suffering from same problems. I would suggest not removing topographic phase temporally, if the spatial baseline is not very large (some time the results are quite good in case of few meters of baseline). If the baselines are large, maybe we need to remove the topo-phase manually.


Hallo Jun,

I experienced the same problem with the “topo-related-fringes” after the “topo-phase-removal”.
Obviously, the data I processed did not display the deformation but the topography.

I suppose it has to do with the processor change in Nov 2015, as you mentioned.
The data I used:

I will now have a try with data acquired after the Nov 2015.


This seems not solved in the ver 4.0 yet. It might be the most important issue I met.

I tried two new scences:

I noticed that multilooking the interferogram before the reomval of the topographic phase caused problems. Look at this:

f.l.t.r.: multilooked phase of original interferogram, SRTM-DEM, topo-phase, phase with topo-phase removed

So I tried without the multilooking:

UL: multilooked phase of original interferogram / UR: phase with topo-phase removed / LL: SRTM-DEM / LR: topo-phase