Alternatives to libgfortran3 on Ubuntu 20.04

Good afternoon everybody!

I’m new to this forum, and regrettably my first post is about an issue which has been already solved…but not on the OS I’m using. The error is returned while creating stack in SNAP on Ubuntu 20.04.

Error: [Nodeld: CreateStack] org.jblas.NativeBlas.dgemm(CCIIID[DII[DIID[DII)V)

I’ve learned from another post that it’s about a dependency error, and it can be solved by installing libgfortran3.
Unfortunately that package is not available anymore and its successors do not seem to work with SNAP/jblas.
Does anyone know a solution/turnaround to this on Ubuntu 20.04?

Thanks in advance for your help!



Ubuntu 20.04 really needs more time to mature, so unless you are using 20.04 because 18.04 doesn’t run on your hardware, you may find fewer issues using 18.04.

NASA’s OCSSW software uses libgfortran3, so those of us who use the NASA software just need to copy it to /usr/lib. If you don’t want to install the full OCSSW package, you can try the rather long and messy procedure posted in this forum.

1 Like

Thanks for your feedback @gnwiii, and for the indication about the NASA alternative! It worked like a charm!

As for Ubuntu 20.04, it is making me struggle on several fronts, you are completely right about that. Nonetheless, I am still a little resistant to downgrade because I like to think that the community will address the issues and figure out a solution in reasonable time. We’ll see!