Biophysical Processor issues using ENVI hdr data

No, the product was created by the sen2r plugin in R.
I’ll follow your suggestions

Unfortunately I had no luck.
I’ll try another approach. I want to mosaic - clip and finally create Biophysical parameters with S2 Level 2 data. I’ll use SNAP.
As I see there is the Multi-size Mosaic.
I’ll try to create a graph builder with this option even if I’m not sure that it works correctly
with S2 level 2 data ( I have read the relative post) .
I can’t see the menu of Multi-size mosaic into Graph-builder in order to change the parameters. Is that right?
Please see the attached file.


Why do you use the graph builder for this step?
Even if you have multiple image products it makes sense test the operations in the gui first before you automate the processing with a graph.

my goal is to create 10-days composite S2 Level 2 product and produce Biophysical parameters (LAI-FAPAR etc) and NDVI NDWI. I would like somehow to automate the process as much as possible.
Ι’m searching the AOI monitoring and Product Library options for downloading S2 data and afterwards,
I’ll follow your advice, to use from SNAP gui the Multisize Mosaic option.
Thanks again for your help.

I understand, automating makes absolutely sense in such a case. I was able to reproduce your error, the tab does not show up in the Graph Builder

Is it an option to automate it by generating the XML yourself and executing it with the gpt? Some usage notes are given here: Multi-size Mosaic will not work with gpt command line



Maybe it’s to much for me now to work with gpt.
I 'm thinking to apply another approach. With graph builder, firstly to resample - subset - NDVI… and
secondly to create a mosaic at the final products. Unfortunately the graph builder gives an error about the NDVI band maths
Please see the attached file. I don’t understand with graph builder doesn’t work with S-2 data

Are other band names suggested when you open the editor by clicking “Edit expression”?

I reinstall the SNAP and the related plugins.
When I create for the first time the model in graph-builder everything it’s okay. I can run
the procedure. But when I retry to run the model then I get an error message about “Undefined symbol B8”
and at “Edit expression” the “Data-Source” have disappeared.
Please see the attached file. I’m struggling to figure out what I’m doing wrong.


I could not reproduce this error - can you please share the graph xml here?

I noticed when I close and reopen the graph than it works normally. I’m sending you the graph xml.

sentinel_2_Biophys_NDVI_10042020.xml (4.6 KB)

Now I’m facing an other issue.
I use Batch processing in order to create the output products (LAI, FAPAR, NDVI, etc) from the two adjacent images. But the model gives me the results of the one image twice (maybe something is wrong at the subset ??) . As I understand with the batch processing I can apply the graph in more than one images.
As I told you my goal is to mosaic the final product in on image containing Biophysical parameters and NDVI.
Please see the attached file

Thanks again for your time

I think this is because the input product is defined in the XML - try to leave it out - I modified the XML:

<parameters class="com.bc.ceres.binding.dom.XppDomElement">

sentinel_2_Biophys_NDVI_10042020_mod.xml (4.4 KB)

This grants that the BatchProcessing tool really goes through the list if input files.

I ran the modified graph model but I also get the same product two times.
Maybe something is wrong in the “subset” or “write” (output)?
Please see the attached file


please check in the metadata if it is the same product or maybe another product but with the same name. I had this once because the Batch Processing somehow mixed the output names.

As I understand it is one product imported twice in the SNAP. The graph saved only the product from the first image.
Please see the attached file. At the left side is depicted the same product imported twice, after the graph processing and at the right side is the batch processing with the two images imported.

hmm, actually this should be handled by the “Keep source product name” option.

Have you tried removing the target name “BiophysicalOP” from the XML as well and let SNAP decide the output name?

As you only use two images - do you need the Batch Processing at all or could it be solved by repeatedly running the graph with the inputs?

Yes I would like repeatedly running the graph in 3 different places.
The “BiophysicalOP" is the default name that automatically is given by SNAP.
I deleted the name but when I run the graph it appears by default. I run the graph but the same issue.
I’ll try to recreate the graph by the scratch and I’ll let you know

Last question about the graph - Builder.
An ideas about how to put a mask cloud to the final product so I get null values?
Thanks again for your time!

you can use the Land/Sea mask operator and use a vector as a mask or simply apply the Band Maths to exclude values based on a logical expression. Can you describe which pixels you want to mask?

Only the pixels that have clouds (NaN value). Finally, I would like a product with biophysical indices + NDVI and mask out all the clouds (plus shadows). I think I must use the scl masks but at what phase in the graph model and how?

Please have a look here - I think this discusses the same approach: Image Classification