Blank result after supervised classification


#22

Hello!

Yes, I reproject to WGS84 and I did the classification from this data. I have tried again only with bands B1, B2, B3 and B4 and still with problem, didn’t show up the result. The frequencies appears with “?”

I think it’s strange, because the KNN and Minimal Distance ratings worked with this same data (NDVI,NDWI,GNDVI and B1,B2,B3,B4).
Here are the results:

This is the result for KNN classification for the same data:


#23

I’m having a bit of problem trying to figure out what is going wrong with the classification process made by KNN classifier.
I have two set’s of images for the same place, one from 2015.11.04 taken by S2A at Orbit number 37 that covers 29TNF area and the other from 2018.09.02 taken by S2B at Orbit 37 on the same region.
I’ve a set of trainning areas that I have applied on the image of 2018 (S2B) and used on KNN classifier:


Thus resulting on the following classification:

Then I’ve applied the same vectors to 2015 image (S2A):

But the output its not, somehow, what I was expecting:

I’ve tried with ML and RF classifier with no problem, but with KNN something it’s not right. Can anyone help me understand what could be wrong or what should I try to test?

(I’ve used a land/sea mask)

"No need to reply. Already solved the problem: Bug in vectors:grin: