Coregistration and Interferogram problem in Ubantu VM

Hello there,

I am currently using Python3 to call the coreg_ifg2run.xml script under the project configuration. I am working on Ubuntu VM. After I execute the command:
python3 project.conf

A coreg and ifg folder has been created, which is good. But What i have also got is the error: No product reader found for file. My SNAP version is the latest V8. I don’t think there’s a problem with the SNAP version.

As attached is my and project.conf. (5.0 KB)
project.conf (740 Bytes)

Have splited the image or not?

And one more thing it will work on python2

It might be helpful to compare the “graph2run” (coreg_ifg2run.xml) files from python2 and python3. You quite the error: “No product reader found for file.”, but the key bit of information is missing: the error: "No product reader found for file ‘/home/…/Project/master’. Your project.conf has 24 lines, with


and a bare filename on the next line:


If you are planning to use this script for large scale batch processing you may may find it helpful add more error checks (e.g., checks for existence of input files). It is common to have more lines of code for error reporting than lines of actual processing.

I agree. The master image has to be defined in one line (path and filename without space or return). Also, the scripts expect the master to end with “_split_Orb.dim” (please see here).

Yes. I have applied the TOPSAR.split.

I tried python 2, but always got an error while i was calling the script. Then I searched the Internet, and they said it’s the python version problem. some packages is not installed in the old python version. So I switched to python3. it worked well in the data processing of Snap to Stamps before I ran into this error.

Yes, it works. Thanks mate.

Good suggestions. I will definitively take it. Thank you so much for you help. Have a good one.