Download tiles

i have the same problems downloading from the scihub API. Unable to unzip, corrupted files…

Dear Olivier,
I had a problem downloading single-tile product. The overall download was OK but the xml header was empty. The https address for the xml file was not exact (“apihub” directory missing in the full address). What I did to fix this issue is to put the following code line:
at line 300 of
It is working well now.
What do you think?

This is due to a change in the metadata that was introduced on June 16, but neither announced nor ever explained. From one day to another, the URL for the various product files changed, dropping the specific hub tag (apihub, scihub). Your replace statement is the correct solution to this. I only discovered this after a week. I guess many users suffered in silence…


Thanks Tristan and Guido, I had corrected the issue for all files before my holidays, but had forgotten the header file. Now it should be fixed. (someone has also raised the issue on github). I had also sent a message to ESA and an anomaly should have been raised.
A bientôt !

Hi Olivier, Hi all
i have a question about your tool: Is it possible to download several tiles in one request ? like this: " --lat 43.6 --lon 1.44 -a apihub.txt -o 51 -t 31TCJ 31TCK "?
I can do 2 requests, but i think i save some time if i just do one…
( Sorry, i posted the same question on the CESBIO multitemp blog …)
Merci Beaucoup

Hi Leo
Sorry, this was not implemented, just run it twice, I don’t think it takes much more time, as most of the time is spent downloading the tile files. Given that ESA is going to change the packaging of its products this autumn to directly deliver the products by tiles (which is a good point, too bad it was not done from the beginning), I don’t think I will implement it.

Hi all,

in my little python tool, I had implemented an option to download a specific tile only, for the initial Sentinel-2A products which may contain several granules. This option hadceased working since an upgrade of scihub. I have had to change the way of telling a folder from a file, using now the file size.

Looks like it works now, both on old and new format (even if not really necessary for the new format :wink: ). Please download the latest version.

Best regards,

I’m trying to use the Olivier’s sentinel-download tool, but without any luck. I’m on a windows machine and have tried with both aria2 and wget. The command I’m issuing (for wget) is:

python K:/PostDoc/R/ForestModeling/ --lat 41.9551 --lon -75.5488 -a K:/PostDoc/R/ForestModeling/apihub.txt --id 2016-06-01 --if 2016-07-01 -t 18TVM -s S2

to download all available S2 products from tile 18TVM from June 2016. I get an xml file (query_results.xml), but no products. I’m not sure what I’m doing incorrectly.

Any help would be appreciated.

This is the output from issuing the command (user and password are hidden below):

wget --no-check-certificate --user=“xxx” --password=“xxx” --outp
ut-document=query_results.xml “
print:“Intersects(41.955100,-75.548800)” filename:S2* ingestiondate:[2016-06-01T
00:00:00.000Z TO 2016-07-01T23:59:50.000Z] producttype:S2MSI1C &rows=100”
SYSTEM_WGETRC = c:/progra~1/wget/etc/wgetrc
syswgetrc = C:\Program Files (x86)\GnuWin32/etc/wgetrc
–2018-01-10 18:00:58--
Connecting to||:443… connected.
WARNING: cannot verify’s certificate, issued by /C=US/ST=A rizona/L=Scottsdale/, Inc./OU= CN=Go Daddy Secure Certificate Authority - G2': Self-signed certificate encountered. HTTP request sent, awaiting response... 401 Unauthorized Reusing existing connection to HTTP request sent, awaiting response... 200 OK Length: 1988 (1.9K) [application/xml] Saving to:query_results.xml’

100%[======================================>] 1,988 --.-K/s in 0s

2018-01-10 18:00:59 (539 MB/s) - `query_results.xml’ saved [1988/1988]