Ellipsoid Correction of ALOS PALSAR L1.1 4pol data in SNAP not supported?

Ok, that’s strange.
I am btw using 6.0 since the earlier version didn’t even allow me to import the data, which version are you using?

I was using 5.0 for this test. Did you import the data with FIle > Import > SAR sensors > ALOS PALSAR CEOS?

Yes I imported it that way.
And now I downloaded quadpol from ASF which worked.
I think my data that I’ve been using is from the ESA open access hub. I’ll try to redownload that to see if it helps.

It was some time ago so I don’t remember if I downloaded in some weird format.
Are there any clues in the naming of the files? The top one is the one not working.

I’ll try to redownload from ESA as soon as their maintenance period is over

as long as it is SLC or Level 1.1 respectively you should be able to fully process it in SNAP.

Well, I can’t really seem to get the quadpol from ESA to work.

As I mentioned it can’t even be opened in Snap 5.0, is that a hint to what is goin wrong here?
This is the error message:

If not, do you have any ideas of what is going wrong here?

did you check if the same file is also available at ASF vertex:

I read that the formats slightly differ, maybe this is one of the outcomes of that.

Yes I tried to find the data there but no quad pol scenes show up in my study area
Northwest of Madagascar: (44.26,-16.89,46.96,-16.89,46.96,-15.45,44.26,-15.45,44.26,-16.89)

unfortunately, not all ALOS data are featured in ASF…
Try to find a quad-pol scene from another location just to see if the problem comes from the ESA data.

I found some quad pol on ASF and it did actually work. It is just not over my area. That means that something is different with the ESA data,but I don’t know what.

But I can open and pretty much do anything with the ESA quad pol data, as long as it doesn’t incorporate Geometric operations. (in 6.0 at least)

PolSARpro makes a difference regarding the ALOS resources from different providers. Could be that SNAP doesn’t fully support both formats.

I can process and use the quadpol data in Polsar, but the issue is still to be able to do some georeferencing.
Does Polsar have any way of geocoding data?

Or can I process the data in Polsar and/or save it in a format that can be read by Snap?

(See edits)
I found this, but it is asking me to link Polsar with the s1tbx, which is weird since it asks for an .EXE file, and the only .EXE file I can find is the one that opens Snap. All files found in the s1tbx module folder are .jar files.

I tried the snap exe file but that one only gives me an error message, not surprisingly.

Is there a way to link Polsar with s1tbx?

I found and installed the sentinel toolbox 1.1.1 but now my previous link is faulty, how can I change a program link in Polsar?

Edit2: Well I apparently didn’t have the newest version of Polsar. Installed it and now it asks for a link with snap. I did that and when I am about to geocode I get this message:

I’m sorry for all the edits. I’ll play around with this a bit now to see if I can get it to work

But if you know the procedure for georeferencing with Polsar I would greatly appreciate any input!

Georeferencing has to be done in SNAP at best, you can import your files into SNAP (no need for version 1.1.1, just use the latest you have) and you can change the links afterwards as well.
Both is explained here: Help installing PolSARpro software step by step on detailed on the windows 7 system

Thank you for the continued help by the way.
But how do I import my files into SNAP in another way that I havn’t tried?

Oh of course!
But then how do I export to PolsarPro format in Polsar?

the files are already written in PolSARpro format during the processing, no need for an export.

These tutorials will help you:

I tried importing a multilooked scene from Polsar into SNAP, but absolutely nothing happens, no error message - nothing. It doesn’t even work in the background or use processor power or hangs. It just doesn’t do anything.
I tried with the PauliRGB.bmp.hdr file.

I did also try with the T11 and 12 files just to see what happens and understandably I actually get an error message saying it doesn’t know its data type.

I’ll read up some more and see if I can figure something out

you are right, I get an error as well when I want to import PolSARpro files.

But in the new version 5.1.1 you can directly address the SNAP command from inside PolSARpro. Worked fine for me.

When I do that I get the “A problem occured during the geocoding” error

It worked well with dual pol though, I’ll try with quadpol from ASF a bit later as well