Error in creating L2A User Product (sen2cor 2.3)

When running L2A_Process I get the usual message saying the process started:
Sentinel-2 Level 2A Prototype Processor (Sen2Cor), 2.3.0, created: 2016.11.18 started ...

Just after that, the process finishes without any message. The log file says:

 <inspection execution="2016-12-02 19:23:00,873" level="CRITICAL" process="5603" module="L2A_Config" function="createOrUpdateL2A_UserProduct" line="3212"/>
 <message contentType="Text">Error in creating L2A User Product</message>

It looks like this was due to missing AUX_DATA and HTML folders.
The previous version issued specific messages about those.

Hi skualos

I have exactly the same problem with the same error message. Unfortunately, I don’t understand how you solved the issue. Where were those folders missing? What exactly did you have to do in order to get it running?

Thanks for your help

Hi. Since sen2cor is not issuing specific messages, at least about those missing folders, my issue might not be the same as yours. I downloaded single tiles from Google Cloud Plataform, and you have to do some modifications for those files to work correctly with sen2cor.

The first thing is to change the name of the downloaded folder to match the requirements of sen2cor (S2A_xxxx_xxx_MSIL1C_…)
So S2A_MSIL1C_… becomes S2A_OPER_PRD_MSIL1C_…

Then, inside the base folder, sen2cor also requires that two another folders be present:
AUX_DATA and HTML. So just create those folders inside the product base folder and it should work.

Another problem I was having, but only in Windows, is that file paths become to long for Windows to handle them.
So I moved the product to c:\ and processed it from there.
I was also having permission issues, so you can look if the folder is not “Read only” and also try to run sen2cor from inside a command lines started as administrator.

Hope this helps, cheers


I got to this page because I experienced the same errors. My fault was that the .SAFE folders were not properly readable. Running the Sen2Cor command as sudo fixed it quickly for me.

I had this issue because of missing AUX_DATA folders. By adding blank AUX_DATA folders to my product, the issue was resolved.

1 Like

Thank you very much skualos for your tips. In my case the problem was that the file was saved in the D folder. Once I placed it on C: then it worked.