Error in SAR image corregistration: Error: [Nodeld: CreateStack] org.jblas.NativeBlas.dgemm(CCIIID[DII[DIID[DII)V)

Hi, I’m trying to coregister one image of ALOS1 with another image of COSMO Skymed. Both images are enough similar between them. For example, they are real data, same polarization (HH), similar acquisition date (only 11 days of difference).
I think one difference is the georeference system: in ALOS is GRS80, while COSMO is WGS84.
Both data formats are native of SNAP (.dim and .data)

I have the following output error when I’m trying to create the stack in Radar->Coregistration feature:

Error: [Nodeld: CreateStack] org.jblas.NativeBlas.dgemm(CCIIID[DII[DIID[DII)V)

Now the questions:

  • It is possible to coregister different sensors in SNAP tool (particularly ALOS1+COSMO)? Which sensors?
  • In case of YES, Which are the necessary and minimum conditions of master and slave images in order to be coregistered? For example: same polarization, same georeference system, etc.
  • What is the meaning of the error? What I’m doing wrong?

Thanks in advance.

Co-registration between different modes or sensors does not work. If you want to co-locate the images terrain-correct them into the same pixel-size and coordinate system first.

1 Like

Sorry I’m a little confused. What is the difference between coregistrate (Radar->Coregistration->Coregistration) and collocation (Raster->Geometric Operations->Collocation)?

You may be able to coregister different sensors but you wouldn’t be able to do insar with them. It could still be useful for change detection or other application where you only care about the intensity values.
The error is coming from the jblas dependencies. Some users have seen this on some linux distributions where fortran libraries are not installed. This may help


As mentioned by @lveci, the error alone refers to the missing dependency, the fastest solution tested with Debian based distributions like Ubuntu/Kubuntu is installing the libgfortran3 packge

sudo apt install libgfortran3

this is all you need and always does the job for me if I set up a new system or instance. However, libgfortran3 is often used as dependency by other packages, therefore it may be installed if your system is “older” which means you already have many packages installed…but it is not obligatory…


Hi, the installation of libgfortran3 solved the problem. But now, I’m having some problems to coregistrate the image set. It’s only working for bilinear interpolation, with ALOS as master and only maximum overlap. I suspect the problem is low overlap between images.

The image below shows the actual result. It’s too much error in coregistration and I need to solve it.
I’ll try with a more overlap set.

Is the orbit-track and beam-mode same in both images?

I’m trying to coregister ALOS1 and COSMO-SKYMED products.
ALOS 1 is 1.5 level, calibrated.
COSMO-SKYMED product is DGM B level. It’s calibrated and terrain corrected.

Attached you can find both metadatas exported by SNAP.
Tell me if you need more information about.

ALOS-H1_5_UA-ORBIT__ALPSRP273806550_Cal_Abstracted_Metadata.txt (23.8 KB)
CSKS4_DGM_B_HI_19_HH_RA_SF_20110305110725_20110305110733_Abstracted_Metadata.txt (18.8 KB)

I’m trying with a new set of images in the same are. In this case, I started with L1A COSMO and L1.1 ALOS1 images.
Applying calibration, multilooking, speckle filter and terrain correction with HTG 1 sec DEM and WGS84. But I have problems with final results…

Attached ALOS1_CSK_residuals2.txt (1.0 MB) it is the residuals file. It seems to be working.

Now here is the result. I don’t see any values in slave coordinates. Always appear Nan values.

I tried with ALOS and COSMO as master images as well, and I’m having the same result.

This is the configuration for coregistration:
Interpolation bilinear
initial offset method: orbit (what is this? is not in SNAP help)
Maximum overlap.

I don’t know what else to try.

You cannot co-register different sensors or products with different beam-model, pixel-size etc. - it simply does not work.

You should terrain correct both datasets with a DEM into the same map projection and continue from there…

1 Like

Yes, as I said before, ALOS1 and COSMO images are both Terrain corrected with SRTM 1Sec HGT, with the map projection WGS84…
What do you mean with “continue from there” ?

Ok if the images are in the same map projection and identical pixel size, you should be able to co-locate them using Create Stack.

Hello Thho,

I have a problem regarding to SNAP, I think you can help me or introduce me some of your colleagues,

my question:

I want to install libgfortran3. I have a fresh install of Debian 10 (Buster). On Buster only
libgfortran4 and higher is available.
Is there any way to upgrade version of SNAP?

I would appreciate it if you could help me…

Have a good day,


There is a similar issue with Ubuntu, where 19.04 (disco) is the latest version to include libgfortran3.
@marpet, would it be possible to include libgfortran3 in the download, or use libgfortran4 instead?

A similar report can be found here in this topic: Error due to missing libgfortran3, while libgfortran4 is installed (OpenSUSE Linux distribution) .

Hi adriaan,

I don’t know if we can resolve this.
It seems that this issue is caused by the usage of the jblas and this wasn’t updated since a while. Probably it would be best to replace jblas by another library, but I don’t know if this can easily be achieved.

Because this is an s1tbx issue, I think @lveci needs to investigate this.


I have installed SNAP 8 in Ubuntu 18.04 and when I try to perform the co registration of a SAOCOM pair I get the same error [Error: [Nodeld: CreateStack] org.jblas.NativeBlas.dgemm(CCIIID[DII[DIID[DII)V)"] despite I have installed libgfortran as is mentioned in this comment

This problem not appear in a computer with Windows OS.


1 Like

I’m having the same issue, the only difference being I’m using Sentinel-1 data.
sudo apt install libgfortran3 appears not to have made any difference.

Not present in SNAP 7 - I am just sticking to this version

@lveci Did you have a solution to this problem? I there was a workaround for 7 does that not work for 8?

jblas should probalby be replaced but testing is needed to ensure it does not create some numerical side-effects.

apparently, I have the same problem. Ubuntu 18.04, the latest version of SNAP (8.0) installed, and the latest version of libgfortran3 already pre-installed (I had the same issue with SNAP 7.0), but this time, it is not working, any new suggestion?