Error using sen2cor v2.5.5-- No such file or directory: 'nul'

I have tested the release of sen2cor on windows.
there was an error:

C:\Users\Administrator\AppData\Local\Sen2Cor-02.05.05-win64>L2A_Process.bat D:\S2B_MSIL1C_20180320T023539_N0206_R089_T51TXK_20180320T042815.SAFE

Sentinel-2 Level 2A Processor (Sen2Cor). Version: 2.5.5, created: 2018.03.19, supporting Level-1C product version <= 14.5 started …
Product version: 14.5. Operation mode: PDGS. Processing baseline: 02.06.
Process L2A_ProcessTile-1:
Traceback (most recent call last):
File “C:\Users\Administrator\AppData\Local\Sen2Cor-02.05.05-win64\lib\multiprocessing\”, line 250, in _bootstrap
sys.stdin = open(os.devnull)
IOError: [Errno 2] No such file or directory: ‘nul’

the problem occurs when no matter processing 10 m images or 20 m images.

Any solutions?

thanks in advance


I just tried your product from the command line and it works fine. Maybe you try it with the --resolution flag:

hello, @ABraun. thanks very much.
I changed a computer which has a win7 system and the sen2cor worked. But there is another error. the reflectance data processed by sen2cor can’t be opened by snap.

Is there something wrong with the result of sen2cor?

did you process all resolutions separately as described here?