GLCM Error

Hello everyone!
I’m currently trying to produce GLCM textures for some processed Sentinel-1 GRD images.
When I try to use the graph builder (to produce the textures and stack them with the original image), The process is executed, but when I try to open one of the bands I’m getting the following error:

Failed to open image view.
java.lang.RuntimeException: DimapProductReader: Unable to read file

When I try to run the GLCM process outside of Graph Builder, I get the following error:
A java.lang.NoClassDefFoundError exception has occurred.

java.lang.NoClassDefFoundError: javax/media/jai/Histogram
at org.esa.snap.raster.gpf.texture.GLCMOp$ProbabilityQuantizer.(
at org.esa.snap.raster.gpf.texture.GLCMOp.createQuantizer(
at org.esa.snap.raster.gpf.texture.GLCMOp.computeTileStack(
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeRect(
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeTile(
at Source)
at Source)
at Source)
at com.bc.ceres.glevel.MultiLevelImage.getData(
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(
at org.esa.snap.core.gpf.internal.OperatorImage.computeRect(
at Source)
at Source)
at Source)
at Source)
[catch] at Source)

I’m using SNAP 8.0/8.0.3 and I’ve tried to re-install it. Sometimes the process works just fine, but I can only process one image. When I try to process another image, I get errors.
I also think I’ve had some other errors in the past few days, but sadly I didn’t report them nor did I write down the names of them. If I recall correctly, one of them had something to do with the histogram (I don’t know if that helps).

Has anyone had some similar issues recently and/or knows how to solve these problems?


I have experieced the same yesterday. Something does not seem right.

I have created a ticket here:

1 Like

The problem has been fixed. The fix should be available in the next release. Thank you for pointing out the issue!

1 Like

Dear jun_lu, thanks for the feed back. Is there an estimate about when the next release will be available?


A module update will be released sometime next week

There were a number of updates installed today however this error continues. I’m wondering if the fix was part of this update batch? or if the fix failed.

There were only updates for the Sentinel-2 Toolbox. The GLCM is contained in Sentinel-1 Toolbox. So the fix was not included in the updates.

1 Like

Is there an estimation about when the update should be released?

I am facing the same issue while trying to run GLCM for Sentinel-1. When should we be expecting the update in the Sentinel-1 toolbox? Also, is there another alternative on how to estimate glcm on SNAP for Sentinel 1 data?

I am also awaiting the update to fix the GLCM issue.

Hello everyone, even after updating SNAP I am facing the same issue:
Any answer to that?

@ABraun any suggestion?

Can you provide the log file?
SNAP FAQs - What to include in a forum post when reporting an issue?

It seems that the file is broken. Can you open it when you try use the ‘Sigma0_VH_db_GLCMMean.hdr’ file next to the .img file?
If not, the file was probably not well written.

clould it be that the path is too long. HAve you tried saving the file (maybe one step before it) at a shorter name, eg. S1.dim