GRD images georeferencing warped?

I’m trying to register GRD images in Matlab with kml files I am importing from Google Earth. I use the GeoTIFFTags.ModelTiepointTag information in the file header to calculate the pixel to lat-lon transformation for the GRD image in order to match my kml files with the GRD image. I’m noticing that I can get a very good alignment for a local scene, but only a few miles away the registration is clearly quite poor, off by tens of pixels. Is this expected or usual? I’m not seeing this sort of problem with images from other sources, such as CosmoSkyMed. If I were to produce a GRD image myself from a SLC file would there be steps to correct this, or is there something I can do to correct it?

You need to terrain correct the GRD images with a DEM and set the output projection to Geographic lat-lon (WGS84) so that it’s compatible with Google Earth.

Is there any sort of guide/tutorial to how to do this?
I’m also a bit unsure of what form the GRD files are in based on your comment. In the tiff header it says:
GCS: ‘WGS 84’
Datum: ‘World Geodetic System 1984’
But you are seeming to indicate that it’s not WGS84?

The geometry of SAR images is quite different from optical imagery (SAR is not a nadir-looking camera but a side-looking radar). If you want to see them in map-geometry you need to terrain-correct, there are tutorials in here:

Hi, I’m very familiar with SAR imagery. I have been working mostly with other commercial platforms (CosmoSkyMed, Risat, etc.) and have not experienced this sort of registration problem. I will look at these tutorials to try to find instructions on how to do the correction I need. I don’t even need anything in any great detail, I’m not looking in the mountains or anything. Basically I’m looking at locations at sealevel only on the order of 10-20 miles apart, and the registration with Google Earth produced kml files is very different.

I’ve not been able to figure out how to do terrain correction on my GRD image. None of the geometric corrections under the radar pulldown menu appear to be applicable, as they all seem to need the complex data. The ellipsoid correction fails with an error about the metadata, as does the Update GeoReference option. Please any advice? Do I need to start from the SLC file and do something different from the default graph?

Starting from a SLC file, is this a correct graph?

You’ll need to add some more information on what you are doing. There isn’t anything simpler than opening a GRD product and applying Range Doppler terrain correction. Are you sure you are opening a Sentinel-1 GRD product. Select either the S1A…zip file or if unzipped, select the manifest.xml and not the GeoTiff files inside the measurement folder.

Oh, my. I have been able to get thing working today. I think that last week I was opening the tif file, instead of the manifest file, which is a mistake I have made before. That is very embarrassing. I apologize for my mistake.

Does my graph for going from SLC files to terrain corrected GRD-like image look right?

@bbarris I have seen that you have resolved this issue. This post is just to clarify the way the imagery is made

The SLC and GRD images are goereferenced in the sense that it is provided with them a set of tie points (in the tiff tags and in the XML annotations) giving the correspondance between SAR timing and lat, lon.

The geo-referencing is done using a simplified earth model which is a flat earth inflated with the average scene height.
In addition, GRD are ground range projected with this earth model.

What are the consequences of that?
For an IW images having for ex. IW1 over the sea and having gradually IW2, IW3 going to the mountains, the average height won’t be 0.
Therefore if you geocode your image with the built-in earth model (i.e the tie-points) the SAR (IW1) data won’t match with the coast lines. The error made in range is related to the error made in the height.

Being this a problem, there are several options:

  • orto-rectification using a better height mode like a DEM. That way the geolocation will be perfect (to the accuracy of your DEM)
  • if the orto-rectification is not an option and if you want a “GRD-like” image:
  • starting from SLC using a different height in the SRGR step(I don’t know how far this is configurable in the S1TBX
  • starting from GRD you could simply estimate the range error induced by the height error made

Nuno Miranda
S-1 Data Quality Manager


Thanks @nuno.miranda.
So consequently it’s correct, if I want to work with an orthorectified GRD image I have to process the terrain correction after the radiometric corrections.

So would you say @mengdahl is right, when he says: “You need to terrain correct the GRD images with a DEM and set the output
projection to Geographic lat-lon (WGS84) so that it’s compatible with
Google Earth.”

Many thanks