How to open Landsat 8 surface reflectance in SNAP

Hi Guys !

I’ve seen some posts about SR L8 data not opening in SNAP. Recently me and my professor came up with the idea how to open sr files and get the correct reflectance value. It turned out that it’s not problem with SNAP but an error in metadata.
Here’s a quick guide how to open surface refletance L8 data in SNAP :slight_smile: :

  1. Unzip the image folder - you should have seven bands images and MTL file
  2. Edit the MTL file from line 45 - where the names of the files are listed . You can see that the names of the images from the folder are different that this listed in the metadata, that’s why they want open .
  3. Change names of the files in the folder exp. LC81900242016130LGN00_sr_band1 change to LC81900242016130LGN00_BAND1 (so the names match the names listed in MTL file)
  4. Because it is surface reflectance we only have 7 bands, in metadata there’s more delate lines with bands 8, 9, 10 etc.
  5. Your metadata should look like this:
    FILE_NAME_BAND_1 = “LC81900242016130LGN00_B1.TIF”
    FILE_NAME_BAND_2 = “LC81900242016130LGN00_B2.TIF”
    FILE_NAME_BAND_3 = “LC81900242016130LGN00_B3.TIF”
    FILE_NAME_BAND_4 = “LC81900242016130LGN00_B4.TIF”
    FILE_NAME_BAND_5 = “LC81900242016130LGN00_B5.TIF”
    FILE_NAME_BAND_6 = “LC81900242016130LGN00_B6.TIF”
    FILE_NAME_BAND_7 = “LC81900242016130LGN00_B7.TIF”
    METADATA_FILE_NAME = “LC81900242016130LGN00_MTL.txt”

save the file, then go to SNAP open the changed MTL file :wink:

TIP. - the first time you will open changed mtl everything will work really slow, try to open product than close it and open again - should work faster.

One more thing to change radiance value to refletance in both normal OLI/TIRS L8 data and SR L8 data open the MTL FILE.
change the value in all the lines (line 102 to 112) with RADIANCE_MULT_(band number) to 0.0001


than change the value in all the lines (line 113 to 123) with RADIANCE_ADD_(band number) to 0


You will get reflectance values from 0 to 1. :wink:

1 Like

Hi, this is pretty nice to see. Honestly we haven’t looked in detail how to support the SR data till now. It is goo to know that there are some issues with the format.
Have you reported this to USGS?


Yes I did :wink: now waiting for the answer.

The normal Landsat data contain different scaling factors to get radiance or reflectance values. But both TOA. Here we talk about surface reflectance.

Hi, I think I did everything that is mentioned but I still cant run it.
Here is the folder and the mtl.

LC81830312017179LGN00_MTL.txt (8.3 KB)

I just checked it and SNAP v6 fully supports Landsat 8 L1T products.

Just open the MTL file with the “open” dialogue in SNAP or simply drag-and-drop it into SNAP.

Thanks!, I just came in to say that I managed to do it. What worked for me is that the end of the name of each band wasnt _BAND1 but _B1. Then I removed the Filename_Band_quality line in the mtl file since I dont have such file in the folder and it worked. I tried dragging another mtl file but I get the error in Snap.

good to hear that it worked, although it is kind of strange. Were you using the latest version of SNAP?

yes, no updates available. I also see you get flag codings and masks, something I dont have when opening it.

You don’t have the quality band in your data. That’s why you don’t see the flags

Yes I dont have t he BQA in my data from earth explorer. I still had this line in my MTL, I had to remove it so I can open the image in SNAP. Any ideas why it is missing from my order?

Maybe the order was not processed correctly. Also some other bands are missing in your data. Maybe retry to download the data. And to verify try also another location and/or time

Thank you, what I tried is that I downloaded the level 1 product for the same date and it directly opened by SNAP, having the BQA file. No issues with naming. I am also albe to run idepix. I will try to copy the BQA to the SR product and correct the MTL and see if such moves are possible :smiley:

Yes well that works but I cant do the cloud mask with idepix, propably because not all bands are present. So I will reorder the product. Hopefully it will be different, otherwise I have to use level1 and to the atmocorrection on my own

Good morning,

I have done the corrections of .MTL file for Landsat 8 L1TP format to work on reflectance TOA data with SNAP…but I still have values in radiance (w/m²/str…) between 0 and 1.6…

I put
RADIANCE_MULT_BAND_1 = 0.0001 etc. and

Thanks for your help,

But a value range of 0 to 1.6 is an indicator for reflectances.
You can also set a property in order to switch between radiance and reflectance, see:

Hi marpet,

I’m trying to process Landsat 8 L1TP data using SNAP by C2RCC processor. I couldn’t able to run it. The following error is popping out as follows

looks like you only loaded band 1 as a tif file into SNAP.

Please use File > Import > Optical Sensors > Landsat to load the enire stack. Problems with opening Landsat data

Hi ABraun

I tried to do as you said but the following error occurs. Please help me to resolve this issue.

where did you download the data and which product level exactly?

I got it now.
Actually, I downloaded Landsat collection 2 data which is not working initially.
Now I downloaded Level-1 GeoTIFF Data Product.

Thanks for your prompt responses. If I’ve any questions in near future will let you know.
Again Thanks