How to prepare Sentinel-1 images stack for PSI/SBAS in SNAP

Great that you found it yourself, good job!

1 Like

Hi @YuL
Sorry for disturbing you, is any solution for the error “error “Cannot find demparms.in in this directory, parent or grandparent”?
I used the command “ps_plot(‘v’,2)” to plot a shaded relief topo as background, but is returned this error message.

Thank you!

Hello,

I am new user of StaMPS and matlab and have been stuck on step (1,1) in StaMPS processing for some time.

I set up Ubuntu according to the rus-copernicus manual, https://www.gis-blog.com/ and forum tips. Previously, I tried to process an example from the rus-copernicus (Mexico City) manual, but each subsequent attempt at computation took a long time. That’s why I limited myself to 5 radar images to eliminate errors and configure all files correctly.


It seems to me that there is a problem with reading data from .rslc and .diff files in the ps_load_initial_gamma script
Can I improve something in the previous calculations / data export?
I am using:

  • Ubuntu18.04 (VirtualMachine on Win10),
  • StaMPS 4.1-beta
  • snap2stamps,
  • snaphu 2.04,
  • matlab 2018a
    Thanks for your help and support

Dear All

I have downloaded StaMPS from https://github.com/dbekaert/StaMPS. Both StaMPS-master and StaMPS-4.1-beta versions have downloaded. I am processing Sentine-1 stack in ISCE and then StaMPS. mt_prep_isce command is running fine but when moving in MATLAB, it is showing errors with respect to load_isce. Then I have started checking both the versions of StaMPS.

  1. In StaMPS-4.1-beta: load_isce.m file is not present under matlab folder
  2. In both the versions of StaMPS, mt_prep_isce is not available under bin folder.

So my doubts are -

  1. how StaMPS can be processed if load_isce.m file is not available?
  2. Why these files are not available? Are these really not required?
  3. Which version is latest and recommended for uage.

With regards
Hari Shankar
PSload

Try this below one.

I had this error after SBAS processing. The ps_plot error happened after closing Matlab for the day, then restarting, which resets parameters (i.e. lambda to NaN). Resolved by rerunning stamps (1,1).

I am using ps_output to export SBAS results.

Does anyone know if ​output is for uncorrected mean velocities i.e. ps_plot(‘v’), or after corrections i.e. ps_plot (‘v-dao’, ‘a_linear’)?

Hello everyone!
After processing 200 interferograms with StaMPS using SBAS method I obtained the following results, with an empty patch.


I found weird that there is only one empty patch, so I re-processed Patch 11 and got this message during step 3:

S_SELECT: 0 ps selected after re-estimation of coherence
No PS points left. Updating the stamps log for this
**

Any suggestions will be appretiated!

@ABraun hey can you please tell me what the files ph_uw in phuw2.mat and ph_mm in ps_plot_ts_v-do.mat exactly give us.



ph_mm contains one less column. are they both LOS velocities? which of these files i use to get vertical velocities.
@suribabu


Hello,
How did you complete with the step which have mentioned in the image.
Should I change the directory of the commands which were shown not found??
Please reply

Hi
I am trying to use the SBAS method, but I think there is something wrong with my ifgs, Can someone tell me how to fix it?
The noisy parts in the middle are water which at the end of the processing are recognized as ps points.



(v-dao)

Dear Ketti

I am also getting the same error. And as per your solution, I have also given the path of triangle and snaphu in StaMPS_CONFIG.bash file as well as terminal. Still I am getting the same error. Can you please help me.

with regards
Hari Shankar

just add this path to .bashrc folder

export PATH=/home/username/stamps/bin:$PATH
Then run
source .bashrc

then process the mt_prep_snap step in terminal and stamps(1,8) in matlab

Hello everyone, I am very new to PSI. During snap2stamps process, i am still stuck on Step-3 i.e, COREG_IFG_TOPSAR.py. Despite trying several times, I do not understand where I am going wrong. Also I am using WSL2 on windows 11





ubutu_vers

Please Help !

Your master image not spilted, please check that and then install libgfortran3 or libgfortran5.

hi everyone, i have problem when run mt_prep_snap. Please help me !

Just keep like this,

/snap2stamps/INSAR_20172406/ 0.42

I try it and still have the same problem

I have mistake with the format of date when running mt_prep_snap

please i have error in stamps processing


how can i try with ps_load_initial_gamma.m step by step
please help @suribabu @ABraun @gnwiii
thank you for your assistance and support