How to uninstall SNAP 6.0 manually on Linux?

My SNAP 6.0 installation got messed up and I am getting java errors relating to loading the java world view plugin. Tried to reinstall SNAP 5.0 and 6.0 without luck.
This is problem has a nasty effect - I am not able to preview any products, which makes it very difficult to select pairs for interferometric analysis.
Thanks in advance!

You should find an uninstall script in the bin folder of the SNAP installation directory. During the uninstall process to remove all SNAP related data.
The World Wind View causes sometimes trouble on Linux, especially in VMs. This is often caused by the 3D graphics card driver. Updating the driver might help and if you are in a VM it might help to enable 3D support.
You can try to switch the World Wind View in to the flat mode. This can be done in the options panel in the World Wind tab of the General section or paste this property
into the file which is located in the etc folder of the SNAP installation directory.
If this still does not help you can remove the World Wind View module:
Delete snap/modules/org-esa-snap-snap-worldwind.jar within the installation directory.
If you then start SNAP you get a warning that this module is missing. Accept it and let SNAP remember the decision.
As a replacement you can use the old world map. You can find it at View / Tool Windows / World Map in the menu or in the toolbar .

1 Like

As Marpet mentioned, the WorldWind View has been problematic. If I run the snap6 GUI on a headless linux server, with DISPLAY set to my desktop, I get:

SNAP -Error
Unable to initialize WWWorldMapToolView: Profiles [GL4bc, GL3bc, GL2,GLES1] not available on device.

Even after setting snap.worldwind.useFlatEarth=true I still get this error and the WorldWind window is blank.

When asking for help, it is best if you include the exact error message and details of your platform.

The viewer is based on NASA WorldWind Java. The NASA site has a forum and demo applications. If your problems are due to configuration issues with your platform, the demo applications may help you track down the problem, which is often due to bugs in the graphics driver. Depending on your platform, there are other tests you can run to check that the graphics driver is working properly. Before wasting time reinstalling SNAP, I suggest you check that your graphics
hardware is working properly. You may need to contact OS-specific forums for assistance.


Going back to the main question of the topic, I wonder if there is a
systematic way to search and find the installation folder of my SNAP on linux? Also an explainable way to uninstall it ? I have been searching for my SNAP installation and until now I found a hidden folder :
This folder does not contain a /bin/ folder though and I can not find any file which lets me uninstall the current installation of SNAP. I attach here an Image of the sub directories of my .snap folder.
Thank you in advance!

For those who might not be very familiar to Unix file system like me, please notice this short explanation.
The snap installation directory therefore is most probably in :
and the file for uninstalling snap is in :
In general using linux commands:
reveal important addresses related to an installed service.


what to do with that uninstall script?
I’m unable to uninstall SNAP.

You don’t provide enough detail for others to understand what is wrong, and my “absent minded professor” memory is more than usually confused because I am also using SeaDAS 7 which is based on BEAM and (unlike SNAP 7) doesn’t provide the Java runtime (JRE). If you can provide more complete details another user with a similar configuration may recognize your issue.

I think the uninstall script uses the same Java runtime as SNAP 6, so if SNAP 6 has Java problems then the uninstaller is unlikely to work. Another common source of problems is running the SNAP installer or SNAP itself as “root”. To sort out these possibilities, please tell us:

  1. does SNAP 6 work?

  2. how are you running the uninstall script (e.g., from a file browser or in a terminal)?

  3. do you get any error messages?

  4. have you upgraded your OS version since installing SNAP 6, e.g., from Ubuntu 16.04 to 18.04 or 20.04?

  5. do you need to preserve your ~/.snap user configuration data?

currently i am using snap 6.0 but i want to use snap 7.0. The uninstall script is there in opt/snap/bin folder. My question is how to uninstall snap 6.0 using that uninstall script?

The default location for a snap install is ~/snap. Installing to /opt requires root privileges, so you probably used sudo to run the snap6 installer. This is known to cause problems and should be avoided. Can you show us the output from ls -ld /opt/snap and ls -ld ~/.snap?

We really do need the answers to questions 2 thru 5 to figure out why the uninstall fails. Have you tried running the snap 7.0 installer (without sudo) using the default location ~/snap?


How to run the Uninstall script?

Note: you can copy and paste text from a terminal directly into a forum post. Screen captures are often hard to read, and it can be useful to copy text from a post when responding.

If you have “sudo” capability, try running the uninstall script from a terminal using “sudo”:

$ sudo /opt/snap/bin/uninstall

If your system is configured with a “root” user and you know root’s password you can try
logging in as root and then running uninstall without sudo in a terminal:

# /opt/snap/bin/uninstall


The uninstall wont wont work for me…

If this doesn’t work, you can manually remove the /usr/local/snap folder.
Also delete the folder .snap in user user home directory.

This should be sufficient.

1 Like

If SNAP was installed using sudo you can supply the path to the uninstall program: <snap_install_dir>/bin/uninstall or use:

$ cd <snap_install_dir>/bin
$ sudo ./uninstall
1 Like