Import Unwrapped result back into SNAP for terrain correction

Yes, I understand that. Here is what it looks like. I have done exactly what the tutorial says. The unwrapping is not executing. The return is c:\temp\export

I have 16GB of RAM and 50GB of space. I have Cygwin64 installed and SNAP is all updated. Not sure what I am doing wrong?

it’s strange that snaphu is not started. Do you have anti virus software that prevents unknown exe files from running?

No, I don’t think so

Nothing pops up and prompts me that something is being blocked.

Is there a problem if I copy and paste the necessary files needed to run snaphu unwrapping from a working folder to the c:\temp\export? Does everything need to be in the same working folder start to finish?

It would be better if you add the directory of snaphu.exe to your system’s PATH variable, as well as the cygwin\bin folder where all dlls are stored.

Ok I added those 2 paths to my system’s PATH variable. Nothing has changed. I still have the same issue.
The return is c:\temp\export. I have no idea what is wrong? I am sure its a small simple thing that we are missing, I just don’t know what it is.

If I open Cygwin64 Terminal and type snaphu, all the snaphu v1.4.2 commands show up. I did try to run the snaphu command there to see if it would work and it says unable to read configuration file snaphu.conf. Is there possibly something that needs adjusted in that file? I have not done anything to the file at all as of now. The screen shot and snaphu.conf file are attached.

I am stuck at this point, so anything you can do to help would be great and I appreciate your time!

snaphu.conf (1.7 KB)

Hi dsmilo,

The reason why you get the error message may because you have edited the snaphu.conf file in windows, the file snaphu.conf is unix format when created, if you edit it in windows, you must use notepade, emacs or vim which will not change the text format. Or you can use dos2unix manually change it format.

Hope this helps,

I understand the shanphu.conf file is in unix format. I only look at these types of files in notepad. For this instance, I have not edited this .conf file, only opened it in notepad to copy and paste the command to try to execute the unwrapping.

In other interferometry software I have used in the past, sometimes it mattered what version of notepad was used to edit. Is there a version of notepad that is better for the unwrapping process?

Do you have any other troubleshooting suggestions? This is still not working. Or do you know someone else I could contact to get some help with this?

have you tried saving it in unix format again? Maybe as snaphu2.conf, then run again?

I have 2 computers. I copied over my exported work to my second computer and started over with the unwrapping process. I started fresh with the snaphu and cygwin download. Everything has been successful so far. The unwrapping is running. Let’s cross our fingers!

It’s still driving me crazy that my other computer won’t execute the unwrapping using snaphu? I have no idea what is going on.

I’ll follow up if everything works out ok with the fresh unwrapping process. Thanks for checking back in.

Ok, so everything worked and looks good! I am wondering what units the results are in though? Here are my steps to help. I used snaphu to unwrap and import the result back into SNAP obviously. The Range Dopler Terrain Correction was done before I exported as a Geotiff to view in ArcMap. This process says that the Pixel spacing is in meters. When I finally look at the resulting displacement image in ArcMap I have a raster value range that looks like meters to me, but I am not 100%. Are all results that are exported from SNAP in meters (as a default)? I understand you can do band math to change this, but is the default always meters?

if you calculate the displacement from the unwrapped result in band math as suggested here, your output is mm (as long as you enter the wavelength in milimeters)

Doesn’t applying phase to displacement run an algorithm across all pixels converting radians to units that would be used when measuring elevation (displacement in the ground)? What I want to know is what the units are after phase to displacement runs? I have a range that totally makes sense, especially if its in meters, but I have no way to tell what the units are.

Unfortunately, the help section is not very specific regarding this tool.
Output=Displacement map is not of sufficient detail :slight_smile:

well if we don’t know that, then how are we supposed to have any authority with our results? Do you know who the question can be raised up to at ESA?

I personally don’t. But the author of each module is named under Help > About
Many of them are more or less active here.

Dear Andereas,

I think the result in this step you refered to is [quote=“ABraun, post:34, topic:6099”]

is not displacement, However, it is Differential Interferogram of two images.