Install Sen2cor 2.2.1 error

Hi everyone,

I have installed the new updates sen2cor 2.2.1 on my PC windows 10 64-bit but I get the erorr as below despite that I have installed the Anaconda and the instillation was successful as described in the following pdf. Page 15

However, could any one please see the error below and tell me what is I am missing ?

Thanks , D

1 Like

This is an error message from the gdal package which is part of the anaconda distribution. Apparently, there is a version installed which is out of date. Please execute the following command:

C:\Users\xyz>conda list gdal

packages in environment at C:\Users\xyz\AppData\Local\Continuum\Anaconda2:

gdal 2.0.0 py27_1
libgdal 2.0.0 vc9_2 [vc9]

If the versions are different to the ones shown here, please execute:
C:\Users\xyz>conda update gdal

After that it (hopefully) should work. Did you had a previous version from anaconda installed before?

Hi @umwilm,
Thanks a lot for your advice. It worked after updating gdal !
However, it worked for 60 m and 20 m resolution and it stopped at 10 m resolution with the below error , any idea how to solve it ! Also How to make sure that the atmosheric correction wen good for the 20m and 60m resolution after L2A proccessing with sen2cor ? Thanks a lot!

Hi Daniel,

if you have a look at the error output you attached, you will see that for some reasons you are executing the previous version of Sen2Cor 2.0.6 instead of 2.2.1. What you observe is a known error on that version and it was one of the reasons for the version 2.2.1. If this is still installed on your system you should remove it. In section 4.4.3 of[L2A-SRN]ESA-EOPG-CSCGS-TN-0014[2.2.1].pdf it is explained how to remove a previous version. Please check also your environment settings, wherther the environment variable SEN2COR_BIN still points to version 2.0.6.


Hi @umwilm ,first thanks a lot for the reply.
but I did not updated the sen2cor so I am still have the old version 2.0.6 which I have managed to process 60 m and 20 m resolution ? so do you think if I updated to the sen2 cor version 2.2.1 the sen2cor running for 10 m resolution will work ?

Hmm, but in the last but one entry in the forum you wrote:

“I have installed the new updates sen2cor 2.2.1 on my PC windows 10 64-bit but I get the erorr as below despite that I have installed the Anaconda and the instillation was successful as described in the following pdf. Page 15”

Read the release note of 2.2.1. It contains all fixes which have been applied. The error you report on 2.0.6 is one of the fixes which have been applied. Sen2Cor 2.0.6 will no longer be supported.


I relaised that I have installed sen2cor 2.0.6 instead NOT the very updated one :confused: and then I worked on it .
I will update the sen2cor version and hope it will work with no problems. Thanks for the advice :slight_smile:


Hi @umwilm,
I have installed the sen2cor 2…2.1 the updated one on Windos 10 64bit but when I tried to run the L2A process, I got this error or not sure what I should call as below from both either using sen2cor tool or cmd command:

C:\Users\user>L2A_Process --resolution 60 C:\Users\user\Documents\Sentinel\S2A_OPER_MTD_SAFL1C

Sentinel-2 Level 2A Prototype Processor (Sen2Cor), 2.2.1, created: 2016.04.29 started …

and then with no process !

Any idea how to solve it! thanks a lot, D

I run the old sen2cor version (2.0.6) because reasons and get the same error you posted above ("…being used by another process").
My solution is to restart the L2A_process again, it will continue from where it stopped. I’ve put the command in a while loop and just restart it until there’s the same number of OPER and USER granules.

Pretty brute solution but I can’t find any other way to get sen2cor to work.

Hi @unnic
Could you please share the the loop command that you made it to solve the problem. I am receiving the following error although I have tried to run the command several times. Thanks , D

It’s a simple python while loop.
You have different problem tough, my sen2cor runs for a while giving output (e.g: Progress[%]: 1060.85 : L2A_CSND_1_2 , elapsed time[s]: 0.180) before crashing in error: could not delete '[S2A_USER_Granule].xml'

From your output it seems sen2cor doesn’t even start. I suggest placing your file in the root directory (C:) to avoid problems with file name length and trying again.

Thanks for the prompt reply, will try now:slight_smile:

I have changed the folder name that contain the .xml file to S2A_OPER_MTD_SAFL1C_ and also the name of the.xml file changed to S2A_OPER_MTD_SAFL1C_PDMC_20151229.xml
So it is working now with the command ::slight_smile:
L2A_process --resolution 60 C:\Users\Documents\ S2A_OPER_MTD_SAFL1C_

@umwilm I met the same problem that ‘No module named osgeo.gdal_array’ ,but when I entered"pip install gdal"in the command line,it prompted an error as below.How can I solve it ? Could you give me some hitns?


Question 1: I was also trying to install the Sen2cor in windows 7, but unfortunately, I could not succeeded. in between it says it requires glymur. As this computer has not access of internet, so could not find the Glymur. In the mean time, I downloaded it from another computer and installed it. But it removes the existing glymur, though version it requires is same and it was failed.

Question 2: In another computer with windows and also internet, I successfully installed the sen2cor, but I could update in snap interface. it say Networking problem in How it can be solved. Aslo, I am unable to update the another issues which are available now.
Thank you in advance.