Is there a need to edit snaphu.conf file?

Sometimes, Phase unwrapping does not work when I directly use the snaphu.conf file in Snaphu. Alternatively, I used to copy all required parameters to a new file and then use the new file in place of actual snaphu.conf file which is generated by Snaphu Export option in SNAP to make it work. Now it starts unwrapping. (I am using Snaphu through Cygwin on Windows10).
I believe this behavior is not expected. Does anybody faced this kind of problem? Is it necessary to edit actual configuration file?

what do you mean by

when I directly use the snaphu.conf file in Snaphu

How did you call snaphu in cygwin?

Snaphu Export option in SNAP created a folder which consists of coherence band, phase band and snaphu.conf file.
Phase unwrapping did not work when I used this snaphu.conf file.

I have installed Snaphu in Cygwin and I could work with Snaphu without any issues.
Do you think above mentioned issue is because of calling Snaphu in Cygwin?

I used both cygwin and the windows command prompt and simply entered the command from the snaphu.conf file. It depends on how you compiled snaphu if it works in windows as well. Please have a look at my documentation:

You have an error when you use the original snaphu conf file ?

what do you mean by ‘use the file’?

As long as I had enough RAM I didn’t experience technical errors.

You can experience, as I did, problem with conf file on Linux due to the log file.

It occurs a segmentation error because snaphu can’t write the log file. But you just have to remove the command line or turn it into comment into the file.

@ABraun I tried the same way as you mentioned. It did not work.
@Sadri I will try as per your suggestion and let you all know.

I tried phase unwrapping in ubuntu 14.04 LTS . When i run the command -
snaphu -f snaphu.conf Phase_ifg_HH_23Dec20­09_26Dec2010.snaphu.img 4672
it gives an error saying-
snaphu v1.4.2 27 parameters input from file snaphu.conf (84 lines total) only one tile–disregarding multiprocessor option Logging run-time parameters to file snaphu.log
Segmentation fault (core dumped)
Please guide me through this. I am not using cygwin terminal.

Comment out the log file line in snaphu.conf file. This should fix your problem.
For more info, please go through Snaphu Export

Also, this may help.

1 Like

Ok I have another addition to the SNAPHU problem. If anyone could help it be great. i am able to do the following in my first system:

  1. Install snaphu for linux through src directory using make command. I am using VMware on windows 10.
  2. i am then able to copy my SNAP exported files to Snaphu ‘bin’ directory
  3. run snaphu with the line given in snaphu.conf file
  4. it runs slowly due to 4gb ram but it runs correctly every time

Here is the main probblem:
I try doing the same in a Xeon dual core Dell 490 with 32 GB RAM and from 3rd step (look above) onward it does not work. Meaning it keeps saying snaphu not installed use apt-get install snaphu …
Now I have replicated every step from my first pc where it works (but is not practical to run it there) into the second system which is a workstation . What am I missing since it just wont run on the workstation. I have gone over the process 20 times to make sure I am not missing anything. Everytime I have re-copied the sanphu-v1.4.2_linux files fresh so as to not use old files.

let me know if anyone can help.

Will be grateful


Hi, did you try this tutorial ? On page 29 there is a VM I have been using since 2016 and it always works fine. It has been tested on different machines - laptops, desktops - without any problems.
Hope this will work for you as well.

hey,I have tried your solution by comment out the log file line in the snaphu.conf file, but the error "segmentration fault( core dump) still comes. Also i have changed <sys/time.h> to <time.h>, still comes the error.
have you tried some other solutions?