Java.lang.NullPointerException (again...)


#22

Thank you so much for your reply Andreas. Your replies always help me.


#23

Hi @ABraun, thank you very much for your advises. Now i have generated some relevant DEM outout. One more help i need. can you please tell me how can i make smooth DEM from the output?


#24

There are some filters you could try when you right-click a band and select Filter band


#25

Thank you very much once again @ABraun


#26

@ABraun @smohit , the problem Java.lang.NullPointerException the problem is generated using the tool Phase to Elevation ( DEM generation) when use a subset from the image. Must be with all image unwrapped phase.


#27

it’s still a bit strange to me, I tried some other examples based on S1 SLC products and the phase to elevation operator works just fine. Haven’t found out what exactly causes the java error.


#28

Me neither @ABraun, but i also did many tests and always i worked whit subset image, because snaphu process take a lot time. In fact, for all swath of interest took 6 hours to generate unwrapped phase… And the phase to height operator works on S1-Toolbox, since snap software does not do nothing.

Greetings and thanks you @ABraun


#29

unwrapping in snaphu surely takes a lot of time. Sometimes increasing the tile numbers can be favourable.


#30

Hi all,
I´ve been experiencing the same java exception problem while doing Phase to Elevation procedure.
I am using SNAP 5.0.8. on Win7 64bit.
I did experiments with multiple input data and actually couldn´t find a pattern in which circumstances this error appears and in which not.
This case caused mentioned error every time I tried:
Datasets:
S1B_IW_SLC__1SDV_20170309T072134_20170309T072204_004628_00811B_C76D.SAFE
S1B_IW_SLC__1SDV_20170321T072134_20170321T072204_004803_00863A_4D19.SAFE
From both datasets I extracted IW3 Bursts 9 and 10 during Corregistration.
Then I did all the steps in order to compute DEM from those. Everything looked fine until I tried to compute Phase to Elevation.

Interesting thing is that when I did this procedure with IW2 from same radar image pair, Phase to Elev worked just fine.
When I merged IW2 and IW3 prior the interferogram generation, I got again the Java exeption error in the end during Phase to Elevation. It looks, there must be some kind of problem with IW3 part of the image which I don´t understand.

Log:

 org.esa.snap.core.gpf.OperatorException: java.lang.NullPointerException
at org.esa.snap.engine_utilities.gpf.OperatorUtils.catchOperatorException(OperatorUtils.java:421)
at org.esa.s1tbx.insar.gpf.PhaseToElevationOp.computeTileStack(PhaseToElevationOp.java:336)
at    org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeRect(OperatorImageTileStack.java:116)
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeTile(OperatorImageTileStack.java:85)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
Caused: org.esa.snap.core.gpf.OperatorException: java.lang.NullPointerException
at org.esa.snap.core.gpf.internal.OperatorExecutor$GPFImagingListener.errorOccurred(OperatorExecutor.java:376)
at com.sun.media.jai.util.SunTileScheduler.sendExceptionToListener(SunTileScheduler.java:1646)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:921)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at javax.media.jai.PlanarImage.getData(PlanarImage.java:2085)
at com.bc.ceres.glevel.MultiLevelImage.getData(MultiLevelImage.java:64)
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:407)
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:393)
at org.esa.snap.core.gpf.internal.OperatorImage.computeRect(OperatorImage.java:73)
at javax.media.jai.SourcelessOpImage.computeTile(SourcelessOpImage.java:137)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at com.sun.media.jai.util.RequestJob.compute(SunTileScheduler.java:247)
[catch] at com.sun.media.jai.util.WorkerThread.run(SunTileScheduler.java:468)

Many thanks for your suggestions,
Jan