NO Processing of sen2cor tool

Hello everyone, despite all comments regarding a positive solution on the issue of “the black console window with no process”, I haven’t manage to get a solution myself. I still have the same problem and i’ve tried everything described for each one of you in this Forum. Is there a clean way out to this problem? I have SNAP 4.0 and all new versions of Anaconda and Sen2Cor 2.2.1 installed, upgraded and integrated. I left default paths to all environment variables. I also gave new paths after all error messages when started the tool at any resolution. I don’t know if i’m missing any step in order to get this thing right. Also, i moved the product close to C:.
I’d appreciate some help please!!

Best regards

Hi @junoangarita,

  • Are you able to execute sen2cor directly from command line?
  • In Tools->Manage External Tools->Edit->System Variables, what variables are listed?

Hey obarrilero, thank you very much for your answer. The thing is i’m not so much of a tech savvy so I actually never tried executing sen2cor directly from command line. Would you please tell me how to go about it? Regarding the variables :

…that’s what I get. There might be something not right about the sen2cor_bin value but that’s what the manual says the Bin is located.


I think your variables are not well configured, but first of all you should check the installation. For that, open a new command line window and:

  • For checking Anaconda installation, execute the command “conda -V”
  • For checking sen2cor installation, “L2A_Process --help”

If L2A_Process command is not found, you can try to change the variables. I think that they should be in your case:
SEN2COR_BIN-> C:\Users\HP Mania\ Anaconda2\Lib\site-packages\sen2cor-2.2.1-py2.7.egg\sen2cor
PYTHON_BIN-> C:\Users\HP Mania\ Anaconda2\python.exe
(check before that these folders exist)

Hey, How are you?

  1. I checked all the installation settigs through the command line window and this is what I got:

  2. The variables weren’t set properly as you said, then I reset them to these:

  3. The tool was executed to some extent that it coppied the SAFE file again as it’s supposed to do with everything inside, however the xml file that was created cannot be oppened. Also the tool stopped for good at 19% at resolutions 20 or 60

  4. Also stopped at resolution 10 with this window popping up:

So, the tool ran but with errors. What do you think might be the problem? Thanx a lot for your help


I was trying the tool today with a different setting and gave out this error:

the only diffent thing I did was checking the “scene only” checkbox.

kind regards


Perhaps some file has been corrupted during one of the failed executions of sen2cor. You could try to remove the Level2 product (which is generated in the same folder where is located the Level1C input product) and re-run sen2cor, as is suggested here: Sen2cor process : AttributeError: 'bool' object has no attribute 'Size'

Hi Omar, I actually solved the problem.

I re-installed everything from scratch, changing two things from the very beginning :

  1. I assigned a path to python.exe from the anaconda install wizard at the beginning of the installation
  2. As I was installing SEN2COR I realized in the command prompt SEN2COR_HOME was assigned a path and that location was different from what I had set in my system variables, so I changed it. I don’t exactly know which of the actions I took solved the issue but it is now solved. Thanx for your time and willing to help.

Now the problem moved to the issue on the 10m resolution correction that is not processed. Let’s check the solutions through the forum. Thank you so much