Pixel Size problem in Mosaicing S1A GRD image

Hi! Im getting Snap Error: Type:IllegalArgumentException Message: Width(0) and Height (0) must be > 0 when mosaicing 2 images and Im setting the pixel size to 20. Its default value is 0.05. I get the error if I set the value to anything greater than 0. The 2 images Im trying to mosaic are pre-processed with the following workflow provided below.

I am currently doing a research about mapping paddy fields using Sentinel 1A GRDH multitemporal images. I need my output to be in 20x20 pixel resolution and with appropriate backscatter(dB) values. For pre-processing the images, my workflow is as follows:

  1. Apply Orbit
    2)Calibration
    3)Multilook (and setting the Number of Range Looks to 2, so that my Mean GR Square Pixel is 20)
    4)Speckle Filter (Gamma Map, 3x3 filter size)
    5)Terrain Correction (Source GR Pixel Spacings:20(m)x20(m) ; and not changing Pixel Spacing(m) which is in default, 10.0)

Please correct me if my interpretation of pixel size is flawed? I’m actually a bit confused about what Pixel Spacing is, too. I suppose I get the error because of my settings for Pre-Processing.
Also, can I get a comment regarding the current workflow I’m following?
Thank you!


Edit:
Ive tried mosaicing using the default pixel size value (0.05) and got mosaic outputs, but it Im not sure of its pixel size anymore and how I should deal with it. Here’s a look at the metadata:

In case you selected WGS84 as the output coordinate reference system: Try the UTM (Automatic) coordinate system instead. It is based on meters and maybe more suitable for this operator. Maybe the pixel size in degrees is not interpreted correctly.

1 Like

Ahh youre right!! It seems I missed the part that I need to express it in degrees, based on my current projection. Thank you ABraun :slight_smile: