Please test the SBAS_snap2stamps

For <BAND_RASTER_WIDTH> , <BAND_RASTER_HEIGHT>, and <DATA_TYPE>, I just modified them follow the code. I modified them manually just because I want to be familiar with the whole process.
For <Raster_Dimensions> which was not modified in the code, you only need to modify the NCOLS , and the NROWS, their values are same as the <BAND_RASTER_WIDTH> and <BAND_RASTER_HEIGHT> respectively.

Thank i will do and i will let you know.

i tried but don’t run, you can show me in detail how you edited the script, with some screenshoots? to see if I did something wrong.

Sorry but I’m out of lab, I can show you the detail tomorrow😃. However, there are several NCOLS(NROWS) in the dim file, I only modified the one under the <Raster_Dimensions> instead of all of them in the dim file

you changed it only in the master’s dim file or in the others?

the dim file I changed was the coregistration pair’s to generate. According to the scripts, it will be generated in the tempcoreg folder.

Did you check the link above which explain how the coregistetion pairs were generate with example?(the process is a little difficult to explain without an example). Here the link is:

@dongyusen @ABraun can you help us?


This error may caused by lib dependence. Did you work on SNAP8? I got the same error in SNAP8, and I installed the libfortran5 to solve it. This link may help:

1 Like

i solved error, but now i have this error.

sorry but I’m a little inexperienced on this thing. @ABraun @Linya-Peng
maybe I got something wrong in the configuration file

how did you solve it?
Sorry that I cannot help much here, I have no experience with these scripts.

There has been a discussion on the ESD operator lately, maybe some of the hints help you: ESD issue with GPT
no cross-posting of questions please.

the error I solved it by installing the libgfortran5 thanks @Linya-Peng , now I have this error on ESD (I will find the link you sent me @ABraun )

I don’t think it’s this mistake, any idea?

recognize this problem? @ABraun

this indicates the process is still running?


The java error message does not say much about the reason of the error.

no the process ends with the error I reported in the image.
regarding the error I asked for help in the link you sent me

@ABraun @Linya-Peng @dongyusen
maybe the problem is because in the xml file there is no ESD operator, when I open it on snap nothing is written?
I ask to better understand the process

this is because the GUI does no longer match the fields in the XML, but currently, only these changes are required.

For XML is ok, already same as @ABraun mention.

I using SNAP 7 and python 2.7 and no problem at all, except the DEM process after December 2020.

I don’t know where the wrong for this case, but I suggest between AOI AREA nad AOI clip, please check again.

You can check AOI AREA and AOI clip area in snap desktop, and please make AOI clip area less than AOI AREA.

In SBAS_snap2stamps for cropping area need 2 steps than in snap2stamp only 1 step, maybe @dongyusen has any explanation about this?

I will dobule check codes and xml files in this week with snap8 and python3.8,


Support of SNAP 8 would be highly appreciated :+1:

i using snap 8.0 and python 2.7 and i have the error mentioned above. i tried your advice but i have the same error, ihave the same coordinates in THE CLIP AOI and i change the AOI LONG E LAT MORE EXTENDED.
I don’t belive that is the problem of python version @ABraun