Problem launching mt_prep_gamma

Hi every one!
I’m new to StaMPS and I seem to be struggling with it.
I’m trying to start PS processing gamma files exported from SNAP using StaMPS export, but I always get this strange error.

Please help cause I seem to be stuck.
Thanks in advance!

could you solve your problem? I get another error: command not found
I installed stamps I don’t know why I am getting this massage

have you edited and sourced the config file correctly? (manual chapter 2.1 Configuration)
Otherwise the scripts are not callable from the command line.
Also explained here:

honestly I didn’t understand what to do exactly! thank you so much I will read these topics carefully.

Please let us know if this brings you forward.

would you please help me with this?

I’ve changed directories although I’m not sure if I did it right!:

have you installed Matlab already? It usually defines a global variable MATLABPATH, which is extended by the stamps\matlab directory so that all scripts in there are found by matlab.

yes I have, should I change any other directory in the config file now?!

you can try to put a # before the line with MATLABPATH so you can still source the script. Later, when you run the Matlab GUI, you can still include the stamps directory in the Matlab Path as described here

thank you so much,seems problem solved
there is one more problem, I can run mt_prep_snap , snaphu, but when I type mt_prep_gamma i get this:
“bash: /home/fateme/Desktop/stamps/bin/mt_prep_gamma: Permission denied” should I install any more programs?

seems that this file is currently restricted regarded its permissions. At best you set the permissions for the entire folder.

But you actually don’t need mt_prep_gamma when you prepared the files in SNAP.

thank you so much @ABraun
I was using a tutorial which used that command ,but after I saw your comment and read somewhere else for stamps4.1b version we should use mt_prep_snap command, is that what should i run now?!

when you prepared the data in SNAP, use mt_prep_snap

thank you so much
the next step is matlab, am I right? do I need any prepration to do?

when snaphu and triangle are correctly sourced with the config file, you are ready to go.
It is a good idea to run mt_prep_snap in a new and empty directory (not in the same as the folders exported from SNAP).

Hi alib1,I have the same problem with you. Have you solved it?

Hello @Smart-InSAR. I solved this problem by commenting line 143 of the script ‘mt_prep_gamma’.

1 Like

hi@ABraun,sorry to bother you.I have a problem, can you help me?
After I use gamma to process the data needed by SBAS, I have this problem when I execute mt_prep_gamma.My rslc is ok for SBAS.Looking forward to your reply.

Sorry, haven’t used Gamma for this yet.
Does the folder and file structure look alright?

thank you for your reply.The files and folders are correct.I have successfully loaded data into StaMPS ,but new I often encounter this problem.