Problem with External DEM - Back-Geocoding

Hi all,

I am trying to coregister S-1A IW data over Greenland and I got the “java.lang.NullPointerException“
when using an external DEM ( in the “Back-Geocoding”.

The graph I use is the standard “TOPSAR Coreg Interferogram.xml”. I tried the processing
step-by-step as well – same problem.

I am using SNAP 4.0.2 on Windows7, 32 GB Ram, i7. I tried to run the processing also with the
GPT – same problem. The processing succeeds when using ASTER GDEM and ACE DEMs
in the “Back-Geocoding” Tab.

The data I used:

The external DEM was saved as TIF in WGS84 using Geographic Coordinates Lat./Lon. The
DEM can be successfully used as external DEM in the “Range-Doppler Terrain
Correction”. It works as well when using the tool “DEM-Assissted-Corregistration”.

I tried to find the problem in “”; however, I don’t see any problems
there (as far as I understand).

Thanks and best regards,


Thanks. The fix for this will be in the next update.

I have exactly same issue. Still no solution for it?

are you sure this is not related to this? SRTM ZIP-files are corrupted or not found

Dear @ABraun

Thanks for help but my area is outside of SRTM (north of Sweden) and I plan to use an external DEM (one of my colleague sent me Sweden national DEM and I am using it) but I do not know why it did not work.

As I cannot use SRTM, so I used ACE30, it works but as you know it is not a proper DEM. I tried to use ACE30 for interferogram formation and subtract DEM by ACE30 but it said that

‘the resolution of the selected DEM is too low, please select a DEM with higher resolution’.

Do you have any suggestion?

Thanks in Advance.

you can manually upsample it to a higher resolution before using it as external DEM. This will not increase its quality, but maybe SNAP then will take it as an input.

OK. How can I do upsampling?
But have you ever used another DEM for Arctic as an external DEM that it worked?

I haven’t used it myself, but many users reported using the Arctic DEM

SNAP has a resampling operator under Raster > Geometric

Thanks. The national DEM for Sweden was in 2 meter resolution, I resampled it in 60 meters and now, it is working.

very good. In case you are not happy with the result

  • you can stepwise increase the spatial resolution to test how high it can be
  • you can test different DEM resampling methods (some might introduce weird patterns if you decrease the resolution so much)
1 Like