Problem with Interferogram Creation


I tried to create interferogram using two sentinel 1 images. I used the following graph builder to create interferogram but the result is nothing but blank. I don’t understand what’s wrong here.

Hi, I have been facing the same issue. For me, the source of error is the S1 TOPS REGISTRATION STEP itself. Can you please check that after stacking, the two slave and master files are generated, what are their intensity files. For me, slave goes zero all the time. Check stats thing, you can find the range of values in the file. For me they are between 0 and some small value.
A quick response will be highly appreciated. Thanks!

1 Like


@chahatchawla001 I am using my University computer and I am away right now. I am so sorry but i’ll get back to you when I am in the University.
Btw is your phase still the purple?

Yes that is the case , but only with the later steps in the Interferogram making step. I don’t have phase data for the loaded files. But all looks file from Intensity, im ,re values. Yes, later on, in the subsequent steps, when the phase are generated, they are purple. But that begins from this coregistration problem itself. Thanks for following up !!!

@chahatchawla001 I think it’s the same with me. After co-registering the slave image has no value in it, and the phase and the coherence are nothing but black. I didn’t have this problem 2 weeks ago but after updating SNAP this problem have become imminent. I think the problem is with the software update maybe!

@Niroj Please be specific while talking of the version. Which version were you using initially ? And to which one you updated ? Did you make the inside the software update or setup something from the scratch itself ?

@Niroj I get empty slave with 6.0.0 . Now I tried downgrading to 5.0.0(i.e. made a different installation itself) as well as after making the in-app update to 5.0.0 to reach to some 5. something. But this made the case worse for me, zero master as well.((both 5.0.0 and 5.something))

@chahatchawla001 Well I was using SNAP 6.0 and it get updated to 6.0.5. I don’t know if the problem is with the update but few weeks earlier it was working fine and It’s weird that you got 0 for both master and slave.

@Niroj Then I guess, what I downloaded and installed would be 6.something and not 6.0.0 . But this page tells that it is 6.0.0 .

Do you both use images of the same track?
Were orbit files applied?
If the image doesn’t have enough significant patterns, the coregistration fails and no interferogram can be generated from this stack.

I highly recommend using the S1 TOPS coregistration module instead of single steps or the graphs you mention.

Some hints on getting correct coregistrations:

Thanks alot @ABraun for following and helping. This is chahatchawla001. Since I am following these -->

it is good to assume that --> they are of the same track and something something.
Refer this also : Coregistration : Empty Slave after stacking using coregistration

@ABraun referring to your suggestion, isn’t applying Orbit Files automatic ? Please guide, if has to be done manually. FYI, I am first stuck at the co-registration itself, so let’s avoid further steps as of now to make the troubleshooting clearer .

only within the TOPS coregistration module?
Otherwise you sould apply it as the very first step.

so it is fine since I am following S1 TOPS co registration. But I doubt they are not being downloaded automatically. Any way to check if they are / aren’t ? My final aim is to get DEM. Is there any other software or API to get this done programmatically ?

Thanks @ABraun @Niroj for helping . I think issue is resolved. What I did is install 6.0.0 and make in software update. Now things started working. I will be back if there is any issue, but it is resolved as of yet.
And for anyone again stuck , I would suggest to check the internet issues and version issues.

@idk I got a issue solved when I changed the DEM to CDEM (Autodownload) in Back-Geocoding Step.

and again the problem is back. While coregistration the slave image becomes zero which hinders the formation of interferogram.

please name your images so we can test.

@ABraun I used
S1B_IW_SLC__1SSH_20180111T205556_20180111T205623_009128_010557_2A2A and S1B_IW_SLC__1SSH_20180123T205555_20180123T205623_009303_010B0C_EF85.

Swath IW3