Processing Error due to SRTM Data Conflict

I run into an error when running sen2cor 2.9.0 to process Level 1C sentinel-2 data version 14.2. It may be related to the terrain correction process as the error message mentioned the access to srtm data (as shown below):

I have encountered a different issue, but still related to srtm data. In that case, moving the directory into an upper level directory solved the problem. However, that is no longer the case with this error I have just encountered.

Any help will be greatly appreciated. Thanks!

Apparently, the error does not happen when no terrain correction is applied… I successfully run the terrain correction for some scenes, but not the other. It seems that the scenes with the failing terrain correction are located at the area where two SRTM scenes need to be stitched together.

In the figures below, note that the “blank” scenes are only found in the center of the area of interest, while scenes on the right and left were processed correctly.

1 Like

Same problem for me!

Got in touch with one of the sen2cor developers. A ticket has been made for further diagnosis. In the meantime, we would have to stick with the non-Terrain Corrected products, I guess.

Any news during this time?

A temporary solution, while waiting for the sen2cor developers to provide a version that corrects the problem, is to comment the 2013 and 2014 code lines of from sen2cor 2.9.0 version. This file is located at \Sen2Cor-02.09.00-win64\ Lib\site-packages\sen2cor. I’ve done tests for several Sentinel-2 products and it seems to work fine.


I followed @vicencpala steps and so happy that it does solve the problem. Currently I have done the test for a single product of Sentinel-2, and now setting up to perform this with more datasets from different scenes that I encountered the processing error. Hopefully everything will work fine

I commented out the same record at code lines 2544 and 2545 in from Sen2Cor 2.10.01. Works without errors.
Thanks for the advice!

1 Like