Ps_plot producing blanks

Hello people,

I’ve tried running ‘ps_plot’ on matlab after running step one of stamps. At first, I received an error which was easily fixed after consulting the forum (Stamps export done. Matlab work done. How to view it again? - #5 by falahfakhri).

However, when I assumed Ps_plot was working, I only received ‘blanks’.

Did I somehow mess up along the way? I don’t really know why this is happening…

First of all, have you completed all steps properly up to stamps(1,8)?

Yes sir, I believe I have.

You have to open Matlab on the working directory (ex: INSAR_masterdate) folder, then try to run all the commands stamps(1,8) then use ps_plot commands.

1 through to 8? In the tutorial (RUS webinar: StaMPS Persistent Scatterer Processing - HAZA12 - YouTube) all they did was (1,1) and then ran the ps_plot command.

I can try running 1,8 and see if that works.

It will definitely work. Because if you want to plot the wrapped phase using ps_plot(‘w’) you should process up to stamps(1,5).

For better understanding, please read below tutorial properly .

StaMPS/ · master · Matthias Schlögl / gis-blog · GitLab

1 Like

I was immediately stopped on step 2.

1 Like

As in replace my version of stamps with that version?

Yes. Then try to run the mt_prep_snap step also.

Just reinstalled the version of stamps that you recommended and now re-running mt_prep_snap.

Just a quick question - should I have done anything with the older version of stamps (such as uninstalling it) or does installing the new version of stamps simply take over? I have deleted the older version of stamps from my computer now, but I was wondering if there was anything else I needed to do?

Just remove the old stamps, then try to install the stamps.
After installation just add this path to .bashrc folder

export PATH=/home/username/stamps/bin:$PATH
Then run
source .bashrc

then process the mt_prep_snap step in terminal and stamps(1,8) in matlab

1 Like

Perfect, thank you so much.

I’ll update you one I run step 1 - 5.

1 Like

Hello @suribabu,

I’ve followed your instructions and I can confirm that everything has been solved. Thank you very much for your time.

1 Like

Hello,@suribabu I had some problems running ps_plot(‘w’), and I had previously added the PATCH path to MATLAB.