PSI using SNAP-STaMPS workflow in Windows Subsystem for Linux (WSL)

PSI can only detect/measure creeping landslides. Sudden mass movements lead to complete phase decorrelation. Interferometry needs coherent scattering between the images. Also, there is a maximum displacement which can be detected between two images which is dependent on the wavelength of the sensor. So I can’t tell what is the matter in your case, but the nature of the movement is critical.

The nature of the movement is slow. There is not a sudden failure.

The materials provided here make suggestions for the variable configuration for cases with slow landslides. StaMPS/ · master · Matthias Schlögl / gis-blog · GitLab

1 Like

Thank you so much.

Hi everyone, can someone help me with this problem? your help is much appreciated.

Please check the solution here: Error in SNAP - StaMPS processing of RS2 data: "Index in position 1 is invalid" - #23 by ttolhurst

Check this also,

Hi, unfortunately, it’s still showing the same error.

Have you installed these following commands,

for snaphu;
sudo apt-get update
sudo apt-get install snaphu
for triangle:
sudo apt-get install triangle-bin

sudo apt-get install gawk
sudo apt-get install tcsh
sudo apt-get install Matlab-support
sudo apt-get make
sudo apt-get build-essential g++

I could not update:
sudo apt-get make
sudo apt-get build-essential g++

it says invalid operation

Use this,
sudo apt-get install make
sudo apt-get install build-essential g++

Thank you, I manage to install,

However, I still get the same error whenever I run MatLab.

Please forward the installation steps of stamps

Install StaMPS/MTI:
tar -xvf StaMPS v4.1b.tar
cd StaMPS v4.1b/src
make install

And I edited the StaMPS_CONFIG.bash file, finally source the file

I use the same method from the manual. Let me know if I need to make any additional steps.

Is there any error while running the mt_prep_snap command?

so far no error,

OK. Try this below stamps code once.

1 Like

hi, Thank you, it worked.

But after my first step stamps(1,1) , i had an issue again.

when i use

ls *1.mat
Error using ls (line 47)

ps_plot(‘v-do’, ‘ts’);
it shows Error using load

oh ok good. Have you completed all the stamps(8,8) steps, without any error?

Hello, I am new to handling stamps and I follow the steps in PSI using SNAP_STAMPS tutorial 1 _Installation and preperation, but when I follow steps 1 and 2, the result is

, and I don’t know where the problem is. The second question is for Matlab. I download it on Windows 10 and then install it in Ubuntu. Is there a detailed explanation More clarification of the installation steps for Matlab and other programs in Ubuntu. Please help and excuse my ignorance. Thank you very much